Squid3 not logging access



  • Hello,

    I'm running pfSense 2.1.

    My project intentions are as follows:

    • Captive Portal with remote radius server authentication

    • Squid3 proxy + SquidGuard3

    • Sarg to provide user accessing reports

    The captive portal is up and running and users can authenticate with no problems.
    Squid3 and SquidGuard3 are also running, but Squid3 isn't logging user access.

    Yes i have logging enabled and squid logs are in /var/squid/logs. The access.log file exists and if i delete it, a new one is created (by squid, i presume).

    I have captive portal patch activated and a limitation to user bandwith (1.5Mbps download, 384Kbps upload - don't know why i'm telling this, but i'm quite desperate).

    I've eve tried a forum user thread who had the same problem and after he had installed both squid and squid3 it started logging.

    I'm proxying on LAN

    This is my squid.conf

    # This file is automatically generated by pfSense
    # Do not edit manually !
    http_port 192.168.0.240:80
    icp_port 7
    dns_v4_first on
    pid_filename /var/run/squid.pid
    cache_effective_user proxy
    cache_effective_group proxy
    error_default_language pt
    icon_directory /usr/pbi/squid-i386/etc/squid/icons
    visible_hostname localhost
    cache_mgr brigintadmin@mail.exercito.pt
    access_log /var/squid/logs/access.log
    cache_log /var/squid/logs/cache.log
    cache_store_log none
    sslcrtd_children 0
    logfile_rotate 0
    shutdown_lifetime 3 seconds
    # Allow local network(s) on interface(s)
    acl localnet src  192.168.0.0/24
    uri_whitespace strip
    
    acl dynamic urlpath_regex cgi-bin \?
    cache deny dynamic
    cache_mem 8 MB
    maximum_object_size_in_memory 32 KB
    memory_replacement_policy heap GDSF
    cache_replacement_policy heap LFUDA
    cache_dir ufs /var/squid/cache 200 16 256
    minimum_object_size 0 KB
    maximum_object_size 4 KB
    offline_mode offcache_swap_low 90
    cache_swap_high 95
    
    # No redirector configured
    
    #Remote proxies
    
    # Setup some default acls
    acl allsrc src all
    acl localhost src 127.0.0.1/32
    acl safeports port 21 70 80 210 280 443 488 563 591 631 777 901  3128 1025-65535
    
    acl sslports port 443 563
    acl manager proto cache_object
    acl purge method PURGE
    acl connect method CONNECT
    
    # Define protocols used for redirects
    acl HTTP proto HTTP
    # This file is automatically generated by pfSense
    # Do not edit manually !
    http_port 192.168.0.240:80
    icp_port 7
    dns_v4_first on
    pid_filename /var/run/squid.pid
    cache_effective_user proxy
    cache_effective_group proxy
    error_default_language pt
    icon_directory /usr/pbi/squid-i386/etc/squid/icons
    visible_hostname localhost
    cache_mgr brigintadmin@mail.exercito.pt
    access_log /var/squid/logs/access.log
    cache_log /var/squid/logs/cache.log
    cache_store_log none
    sslcrtd_children 0
    logfile_rotate 0
    shutdown_lifetime 3 seconds
    # Allow local network(s) on interface(s)
    acl localnet src  192.168.0.0/24
    uri_whitespace strip
    
    acl dynamic urlpath_regex cgi-bin \?
    cache deny dynamic
    cache_mem 8 MB
    maximum_object_size_in_memory 32 KB
    memory_replacement_policy heap GDSF
    cache_replacement_policy heap LFUDA
    cache_dir ufs /var/squid/cache 200 16 256
    minimum_object_size 0 KB
    maximum_object_size 4 KB
    offline_mode offcache_swap_low 90
    cache_swap_high 95
    
    # No redirector configured
    
    #Remote proxies
    
    


  • use squid3-dev to have captive portal integration on squid.



  • @marcelloc:

    use squid3-dev to have captive portal integration on squid.

    I've done as you told. Not working also though.

    I've discovered (through netstat) that the port squid should be listening is closed. Any ideas?



  • @ptbman:

    I've discovered (through netstat) that the port squid should be listening is closed. Any ideas?

    Enable ipv6 on system -> advanced.

    It's something with squid compilation on freebsd/pfsense.


Log in to reply