Local Subnets not talking



  • Hello All! I have searched the internet and also throughout the forums here and I cannot find a solution to my problem. We use a pfsense firewall, which has been working great. We just had an IP phone system installed today, which is on another VLAN. So, we have my network VLAN A subnet of 192.168.0.0/24 and the new IP phone VLAN B of 172.16.2.0/24. On VLAN B there is an IP that we need to access from VLAN A that runs some remote software - this IP is 172.16.2.1. We have it setup so that 192.168.0.3 goes to 172.16.2.1. I have tried everything to be able to ping this IP address to no avail. Here are some things that I have tried:

    1. Setup a rule in the firewall to allow anything on the LAN side to pass - Ping results in request timeout.
    2. Setup static route - Destination 172.16.2.0/24 Gateway 127.0.0.1 - Ping results in TTL exceeded, which tells me this creates a loop.
    3. Ping 192.168.0.3 - get a reply
    4. Change local computer's gateway to 192.168.0.3, the web page that we need to open at 172.16.0.1 opens as it should.

    As you can see, there is something in the pfsense settings that are keeping me from getting the the other subnet.

    Any ideas that you have are greatly appreciated!



  • What do you mean that you have 192.168.0.3 going to 172.16.2.1. Do you mean that you have a firewall rule or a NAT setup for this. You do not need a route. IF there are FW rules in place, pfsense will route between internal subnets.
    My suggestion would be to remote the route you have created.
    Check both the VLAN interface FW rules and the LAN to make sure that you have allowed the traffic to pass. If you have setup a Gateway on LAN or VLAN interface, you are going to have remove that as well.
    Check out your routing table to make sure that it all looks good.


Log in to reply