Problemas no SARG



  • Olá Pessoal,

    Recentemente migrei meu pfsense para a versão 2.1 e reparei que depois disso o sarg anda meio esquisito, hora gera relatórios hora não. Quando tento gerar o relatório pelo console com sarg -x ou somente sarg ele fica na tela abaixo e não sai dai…..

    alguém pode me ajudar? utilizo ele aqui em conjunto com squidguard, vou postar as telas de configuração..  na versão 2.0.3 ele funcionava normal...

    Diego




    ![config 2.jpg](/public/imported_attachments/1/config 2.jpg)
    ![config 2.jpg_thumb](/public/imported_attachments/1/config 2.jpg_thumb)



  • Pode ser bug no pacote, já tentou passar o rotate para o squid com uma quantidade de dias maior?



  • Marcelo,

    no meu squid o rotate está marcado para 60, se for um bug no pacote está explicado pq no pfsense 2.03 funciona normalmente e aqui não

    outra sugestão?

    abraços

    diego



  • O Normal é você marcar só no sarg ou só no squid. Marcado nos dois  dá inconsistência no relatório.



  • Olá Marcelo,

    Estava marcado nos 2!

    retirei o do sarg pra fazer um teste, vou testar hoje!

    abraços,

    DIEGO



  • Marcelo,

    Esse teste não rolou não! tem alguma ideia de como faço para descobrir aonde está o erro? pq tem hora que o sarg gera o relatório e tem hora que não gera, se eu ficar tentando uma hora vai…

    Outro teste que fiz, foi no squid 3 -dev com aquele código para informar o bloqueio da pagina.
    marquei a opção no squid mas o sarg não estava bloqueando a pagina, tive que incluir manualmente no squid.inc o código que usava no pfsense 2.03.

    
    acl sglog url_regex -i .*sgrd=ACCESSDENIED
    http_access deny password sglog
    
    

    depois que fiz isso o log começou a mostrar o "denied" corretamente

    Abraços.

    DIEGO



  • A opção do squid3-dev funciona aqui.
    Veja a configuração resultante do squid e veja como o pacote está incluindo.
    Talvez seja uma questão apenas de posição da acl.



  • @marcelloc:

    A opção do squid3-dev funciona aqui.
    Veja a configuração resultante do squid e veja como o pacote está incluindo.
    Talvez seja uma questão apenas de posição da acl.

    vou olhar isso e te falo…

    olha que coisa esquisita! ontem gerou o relatório normalmente as 23 horas, depois não gerou mais, abaixo umas imagens, fui no console para tentar gerar  o relatório agora pouco e foi gerado normalmente. Mas se você reparar nas datas, não saiu a data de hoje e sim a data de ontem.
    Se eu tentar visualizar pelo pfsense a aba relatório não foi atualizada, consta como ultimo relatório o de ontem as 23 horas e não mexi nas configurações, são as mesmas de quando usava o pfsense 2.03






  • verifica o horario do agendamento no cron.
    você ainda está rodando os logs no squid?



  • Olá Marcello

    O Log do squid tá desabilitado, mas o do squidguard está ativo, vou fazer o teste desabilitando ele também.. percebi agora que acessei o Cron..

    o agendamento do sarg no cron está conforme a imagem

    abraços.

    ![Sem título.jpg](/public/imported_attachments/1/Sem título.jpg)
    ![Sem título.jpg_thumb](/public/imported_attachments/1/Sem título.jpg_thumb)



  • Olá Galera,

    alguém tem mais alguma dica para esse problema do  sarg no pfsense 2.1 ?