Installation error



  • Hi!

    I tried in server 2012 R2 Hyper-V and NO go.
    Tried with dynamic and fixed disks and I used image ISO for full install.

    Istn`t FreeBSD 10 supposed to be virtualisation friendly?

    Regards,
    M




  • Tried with todays snapshot same error…
    More details:





  • Rebel Alliance Developer Netgate

    That's probably due to some outdated (for 10.x) bits in our installer that need to grow up a bit. Things that used fdisk/boot0cfg and MBR in general need to be moved to GPT and such. It works OK for many but some situations may be more sensitive to that need.



  • OK so no 2.2 on Hyper-V.
    Are there plans to support it?



  • there are volunteers, working on better hyper-v performance.

    @zootie:

    I think I figured it out. I had to go through some false starts; but,  with minor changes to pfsense tools, I finally was able to  build an ISO that runs the live CD and installs using the synthetic device drivers. I'll post more details once I run some more tests.

    With any luck, this will help the community short term, maybe allow to have an official Hyper-V edition within the pfSense codebase, and give key4ce and team a head start on making a CARP enabled version.

    @gonzopancho:

    Me too, Peter.

    Let's move pfSense forward.  Getting it available on new platforms is one way of making forward progress.

    I would really like to see pfSense on Hyper-V and Xen.  I'm just looking for some assistance in making it happen.

    so it'll happen some day :)

    For now i guess you'd have to wait a couple of snapshots before you even get to install it ;)



  • I am aware of 2.1 being modified to support Hyper-V.
    But 2.2 supports systethic drivers out of a box (because of FreeBSD 10) and LiveCD is working great.

    I suppose I could do 2.1 install and upgrade to 2.2 :)



  • @maverick_slo:

    OK so no 2.2 on Hyper-V.
    Are there plans to support it?

    I've installed on Hyper-V with no issues. I used the pfSense-LiveCD-2.2-ALPHA-amd64-20140326-1633 build.

    Peter



  • Hmmm I used i386 build.
    U used Gen1 or Gen2?

    I suppose Gen1.



  • Just tried with amd64 and it works.
    So just 32-bit has issues.

    Is 64-bit installer different?



  • @maverick_slo:

    Hmmm I used i386 build.
    U used Gen1 or Gen2?

    I suppose Gen1.

    So far only used Hyper-V 2, not tried on Hyper-V 3 yet. That is the next test when things work a bit more…..

    Peter


Log in to reply