Cant install on Dell PowerEdge R200



  • Hey guys,

    For starters, i am new to pfsense. I tried to install it on a Dell PowerEdge R200 machine but along the way, i get the error below;

    freeBSD/x86 boot
    Default: 0:fd(0,a)/boot/kernel/
    boot:

    How do i get passed this error for me to install pfsense 2.1 on the this machine?

    Thank you



  • Have you connected the hard drives to the onboard controller or are you using some DELL SAS5/ir most of those units shipped with?
    If still on the SAS Controller grab yourself a SATA cable and connect the HDD to the onboard controller.

    EDIT do not forget to enable onboard SATA as it is disabled in bios as a default i think EDIT



  • @Toyer
    thanks for your post. I managed to install pfsense on a flash drive of 8gb. I dont feel comfy with running pfsense on a flash drive. I have an 80gb hard disk, SATA 0. it sets up well till the point when i am partitioning the hard disk. I intend to use the entire disk, but as i go on with the setup, i get an error.

    Execution of the command

    /sbin/bsdlabel -B -r -w ad6s1 auto

    Failed with a return code of 1.

    How can i correct this


  • Netgate Administrator

    If you are running from flash just use the NanoBSD images. They are designed especially for that purpose and will not ware out the flash.

    Steve



  • You might try installing from a boot CD.  I've done a number of installs on Dell servers and I seem to recall some weird situations where a flash install wouldn't get past some part of the drive partitioning/formatting, but a CD install would.

    I never spent any time trying to track it down since the CD install went just fine.

    You may have to get into the Bios to setup the boot device if you can't use F12 during the  POST to select the CD for booting.

    It's worth a try anyway, since it's pretty easy to do.



  • I install pfSense on Dell R210's all the time - usually have to disable the onboard Broadcom NICs during install and then re-enable them after I've added the following lines to the /boot/loader.conf.local file

    kern.ipc.nmbclusters="131072"
    hw.bce.tso_enable="0"
    hw.pci.enable_msix="0"

    -ct


Log in to reply