Can't get embedded image on CF



  • I know that this is probably real easy but I can't seem to find a good program to put the embedded image file onto a CF card. I'm using Windows 7 and I have searched all around for a program to do this. I tried physdiskwriter, but I keep getting 'physdiskwriter.exe' is not recognized as an internal or external command, operable program of batch file. What is the best way I can get the image onto my CF card.



  • Make a folder somehwere - e.g. C:\pfsense
    Put physdiskwrite.exe in there.
    Put the pfSense .img.gz file in there
    Start a cmd window with Administrator privs.
    C:
    cd \pfsense

    Then use physdiskwrite

    I do it all the time.



  • you can use usbit.


  • Netgate Administrator

    You can use Win32 Disk Imager: http://sourceforge.net/projects/win32diskimager/
    It can't extract the image from the gzip file 'on the fly' like physdiskwrite does so you have to extract it yourself first.

    Steve


  • Rebel Alliance

    I'm using "physdiskwrite 0.5.3 + PhysGUI" since long time, and it works Ok for me…..



  • Well I went back and did as suggested with physdiskwrite and it still will not write because the card is a 4GB card. I typed in -u and -d1 for the overide, but it still will not write. States it cannot access the disk. So I tried usbit. Got the image on the card, but kept running into ad0:FAILURE-READ DMA TIMEDOUT LBA=7806957 and so on during boot. So I erased the card and made sure that physdiskwrite could still see the card and its sectors. Still couldn't write to the card. Tried physdiskwrite with GUI and better luck, it wrote to the card. Problem is I still got the same error on boot. When using either physdiskwrite with GUI or usbit, does the image need to be extracted first? And maybe I have the wrong format on my card. What format should I be using. The cards came as FAT32. I just don't want to use another card and mess it up too and be down CF cards. Thanks for the help.


  • Banned

    @TricBox:

    And maybe I have the wrong format on my card. What format should I be using. The cards came as FAT32.

    None. You should delete any partitions (e.g., using diskpart clean) if you are still having some whacky problems with writing.



  • My instructions for this are attached, cut down from my internal installation doc. This is a Word document, but I could not attach that, or PDF. I renamed it to .txt - youwill need to rename it to .doc to read it.

    pfSense-CF-card-write.txt


  • Netgate Administrator

    What image are you using and what hardware are you trying to boot the CF card on?
    The errors you're seeing look like what happens if you try to boot an image that has DMA enabled in a slot that doesn't support it.

    Steve



  • First I want to thank phil.davis for the instructions.  I believe I had success with the right, this time the boot got stuck in the beginning. So I figured I would post my hardware per Steve's suggestion maybe that is the problem.  I'm using: Intel D845GVSR motherboard with a Celeron D 2.8 processor. I'm using a SYBA/SD-CF-IDE-DI RTL adapter (Item 22-998-003 from Newegg) with a 4G CF card from Team (item 20-313-224 from Newegg).  I suppose if I cannot get it on the card I could just use the fard drive, but I was hoping to use a CF card. Thanks for all the help.


  • Netgate Administrator

    I can't tell from the hardware specs. Read this for a description of the possible problem:
    http://www.fccps.cz/download/adv/frr/cf.html
    If you examine the adapter you should be able to see if the dma pins are connected.
    Are you using the nano+vga image?

    Steve

    Edit: No comments in the product reviews relating to dma problems.  :-\



  • I am using the nano+VGA image. Thanks for that link on c.f. cards and adapters.
    I'm going to go over my documentation and research my equipment.


  • Netgate Administrator

    Last time I looked at it (admittedly a while ago!) the nano+vga image has DMA enabled where as the the nano (serial console) images have it disabled.
    It's easy enough to disable DMA once you've booted by editing loader.conf file but to get there you have to interrupt the boot process and feed it a kernel line to override the DMA option. I can't actually remember the incantation off hand….

    Edit: Interrupt the boot precess to get the boot loader prompt and try typing:

    set hw.ata.ata_dma="0"
    set hw.ata.wc="0"
    boot
    

    You may not need the write cache line but it won't hurt.

    Steve



  • Well I looked at the documents for the adapter and it states :Supports Directly Plugged into IDE Connector on the Motherboard Without an IDE Cable and Great for Linux-based set-top boxes, routers, firewalls, diskless network clients, industrial computers and any other device requiring rugged solid-state storage. I also believe it also stated it was UDMA. So I may have another CF card at home and will try that card too because I suppose it could be my card.



  • Now this may be a dumb question, but if the image actually made it onto the card, when you put in physdiskwrite -a will it still show the full amount of the card as available? I was thinking the image actually made it onto the card, but if all of the card is still available maybe not. Or would diskpart be better to verify image is written.


  • Netgate Administrator

    It's possible the 4GB image is larger than your '4GB' card. Manufacturers like to give you less than you paid for, 4000MB for example. Usually physdiskwrite (or any image writing software) would show an error when the media is too small. To be sure that isn't an issue you can use the 2GB or 1GB image instead.

    To check the card you need a program that can recognise UFS slices (partitions). I don't think diskpart or any Windows software has any UFS support. I'm not sure what you could use for that. Gparted maybe?  :-\ It has some limited support for UFS (detect only).

    Maybe this: http://ufs2tools.sourceforge.net/
    I've not tried that.

    Steve



  • Thanks to all! Got the card embedded and it has booted.Cards have IP addresses. Now if only I can get to the webGUI then I would be in good shape. I may have an IP conflict. It is attached to my Verizon fios router with my LAN connected to a Unmanaged switch. But I can't get to the GUI. My pc doesn't get an address.Funny thing though, if I connect my computer back to my vz router and go to
    192.168.1.1, it pulls up the vz sign on page with pfs symbol on the tab. I thought I could run pfs behind the vz router. I have another vz router configured to be a bridge, but since my network distributes tv I have small windows when people are not using the network so I wanted to test it out first before I remove the first vz router.


  • Netgate Administrator

    Yep, sounds like both devices are using 192.18.1.1 for their LAN.
    Change the pfSense LAN address/subnet to something else. Perhaps 192.168.10.1/24.

    Steve


Log in to reply