Squid3-dev netdb is looking for /var/log/squid directory



  • Tested with squid3-dev 3.3.10 pkg 2.2.1

    squid3-devel netdb is looking for /var/log/squid directory

    cat /var/squid/logs/cache.log | grep netdb
    2014/03/20 14:51:52 kid1| Logfile: opening log stdio:/var/log/squid/netdb.state
    2014/03/20 14:51:52 kid1| ERROR: logfileOpen stdio:/var/log/squid/netdb.state: (2) No such file or directory
    

    Workaround…

    cd /var/log
    ln -s /var/squid/logs squid
    

    squid directives, http://www.squid-cache.org/Doc/config/

    I'm thinking if ICMP activated is necessary at default installation. In general, no parents for pfSense's proxy.



  • How do I disable pinger in Squid?
    http://forum.pfsense.org/index.php?topic=19768.0

    Squid starts many ' pinger ' processes
    http://forum.pfsense.org/index.php/topic,9737.0.html

    pinger_enable off at Custom Options and stop/start the proxy (squid3-devel).

    stop/start is necessary. If not, pinger process isn't closed.

    http://www.squid-cache.org/Doc/config/pinger_enable/

    Note: To disable ICP I needed also to put icp_port 0 at Custom options. WebGUI says about it:

    ICP port	
    This is the port the Proxy Server will send and receive ICP queries to and from neighbor caches. Leave this blank if you don't want the proxy server to communicate with neighbor caches through ICP.
    

    but blank or 0 doesn't work.

    So, two lines at squid.conf for icp_port, first with 7 and second for 0. But it works!



  • Both values and variables "icpport" and "icp_port" are used throughout "squid.inc".
    I've search and replaced "icpport" with "icp_port". (just to be sure the settings "value" and the variable "value" is equal throughout the inc file)

    Entering a number now results in that number as the icp_port in the conf file.
    However the value "0" is treated like "blank" and is replaced with the default value off "7", which is wrong when you want to disable the icp_port.

    Changes in 3.0 icp_port
    New default to require the feature to be enabled in squid.conf:
    
        Default: 0 (disabled)
    

    squid.inc : line 931

    $icp_port = ($settings['icp_port'] ? $settings['icp_port'] : 7);
    

    maybe this will be an option?

    $icp_port = ($settings['icp_port'] ? $settings['icp_port'] : 0);
    

    Then leaving blank or entering "0" equals to the icp_port being turned off.



  • Ok, thanks!

    Are you the code maintainer for squid pfSense packages?



  • No, sorry..



  • Ok, no problem. Thanks for your feedbacks!

    I disabled also pinger, but still having logs about netdb (?). It's not a problem for working but I document it…

    Pinger disabled

    cat /usr/pbi/squid-amd64/etc/squid/squid.conf | grep pinger
    pinger_enable off
    

    netdb logs

    tail /var/squid/logs/cache.log 
    2014/03/31 04:13:25 kid1| NETDB state saved; 0 entries, 0 msec
    2014/03/31 05:13:06 kid1| Logfile: opening log stdio:/var/log/squid/netdb.state
    2014/03/31 05:13:06 kid1| Logfile: closing log stdio:/var/log/squid/netdb.state
    2014/03/31 05:13:06 kid1| NETDB state saved; 0 entries, 0 msec
    2014/03/31 05:55:15 kid1| Logfile: opening log stdio:/var/log/squid/netdb.state
    2014/03/31 05:55:15 kid1| Logfile: closing log stdio:/var/log/squid/netdb.state
    2014/03/31 05:55:15 kid1| NETDB state saved; 0 entries, 0 msec
    2014/03/31 07:02:59 kid1| Logfile: opening log stdio:/var/log/squid/netdb.state
    2014/03/31 07:02:59 kid1| Logfile: closing log stdio:/var/log/squid/netdb.state
    2014/03/31 07:02:59 kid1| NETDB state saved; 0 entries, 0 msec
    

    proxy processes, no pinger

    ps aux | grep ^proxy
    proxy  13680  0.0  0.3 64640 17016  ??  IN    9:47PM   0:02.73 (squidGuard) -c /usr/pbi/squidguard-squid3-amd64/etc/squidGuard/squidGuard.conf (squidGuard)
    proxy  13921  0.0  0.2 64640 12520  ??  IN    9:47PM   0:00.10 (squidGuard) -c /usr/pbi/squidguard-squid3-amd64/etc/squidGuard/squidGuard.conf (squidGuard)
    proxy  14247  0.0  0.2 64640 11008  ??  IN    9:47PM   0:00.04 (squidGuard) -c /usr/pbi/squidguard-squid3-amd64/etc/squidGuard/squidGuard.conf (squidGuard)
    proxy  14417  0.0  0.2 64640 11008  ??  IN    9:47PM   0:00.04 (squidGuard) -c /usr/pbi/squidguard-squid3-amd64/etc/squidGuard/squidGuard.conf (squidGuard)
    proxy  14456  0.0  0.2 64640 11008  ??  IN    9:47PM   0:00.04 (squidGuard) -c /usr/pbi/squidguard-squid3-amd64/etc/squidGuard/squidGuard.conf (squidGuard)
    proxy  14788  0.0  0.2 64640 11008  ??  IN    9:47PM   0:00.04 (squidGuard) -c /usr/pbi/squidguard-squid3-amd64/etc/squidGuard/squidGuard.conf (squidGuard)
    proxy  14850  0.0  0.2 64640 11008  ??  IN    9:47PM   0:00.04 (squidGuard) -c /usr/pbi/squidguard-squid3-amd64/etc/squidGuard/squidGuard.conf (squidGuard)
    proxy  14951  0.0  0.2 64640 11008  ??  IN    9:47PM   0:00.04 (squidGuard) -c /usr/pbi/squidguard-squid3-amd64/etc/squidGuard/squidGuard.conf (squidGuard)
    proxy  84290  0.0  0.4 57188 21224  ??  SN    8:20PM   0:34.88 (squid-1) -f /usr/pbi/squid-amd64/etc/squid/squid.conf (squid)
    proxy  86450  0.0  0.0 11252  2124  ??  IN    8:20PM   0:00.01 (unlinkd) (unlinkd)
    proxy  86470  0.0  0.0 11620  2264  ??  IN    8:20PM   0:00.01 diskd 86312964 86312965 86312966
    


  • bellera, what I did is easy, create the folder/file and done.
    Latter I will have time to see where that file is created and fix it.



  • @Tikimotel:

    squid.inc : line 931

    $icp_port = ($settings['icp_port'] ? $settings['icp_port'] : 7);
    

    maybe this will be an option?

    $icp_port = ($settings['icp_port'] ? $settings['icp_port'] : 0);
    

    Then leaving blank or entering "0" equals to the icp_port being turned off.

    fixed. Thanks for your feedback.



  • @bellera:

    squid3-devel netdb is looking for /var/log/squid directory

    cat /var/squid/logs/cache.log | grep netdb
    2014/03/20 14:51:52 kid1| Logfile: opening log stdio:/var/log/squid/netdb.state
    2014/03/20 14:51:52 kid1| ERROR: logfileOpen stdio:/var/log/squid/netdb.state: (2) No such file or directory
    

    To disable ICP I needed also to put icp_port 0 at Custom options. WebGUI says about it:

    Fixed! Thanks for your contribution

    netdb path is forced on squid.conf and added Disable ICMP option on squid gui.



  • Awesome Marcelloc  ;)


Log in to reply