Squid3 language error messages



  • Tested with squid3-dev 3.3.10 pkg 2.2.1 package

    Language	
    Select the language in which the proxy server will display error messages to users.
    

    I selected ca (Catalan) language and I've got the following warnings:

    cat /var/squid/logs/cache.log | grep ca-es
    2014/03/31 13:33:46 kid1| '/usr/pbi/squid-amd64/etc/squid/errors/ca-es/ERR_DNS_FAIL': (2) No such file or directory
    2014/03/31 13:33:46 kid1| WARNING: Error Pages Missing Language: ca-es
    

    I think squid is using the browser's language-country (Catalan-Spain), no matter that it's configured in this option.

    Workaround

    cd /usr/pbi/squid-amd64/etc/squid/errors
    ln -s ca ca-es
    ls -l | grep ca
    drwxr-xr-x  2 proxy  proxy  1536 Nov 26 20:53 ca
    lrwxr-xr-x  1 root   proxy     2 Mar 31 13:35 ca-es -> ca
    lrwxr-xr-x  1 root   wheel     2 Nov 26 20:53 en-ca -> en
    lrwxr-xr-x  1 root   wheel     2 Nov 26 20:53 fr-ca -> fr
    

    like for en-ca (English-Canada) and fr-ca (French-Canada).


Log in to reply