PFsense 2.1.1 with RANCID



  • Hi.

    I need assistance in setting up RANCID to backup my PFSense firewalls running 2.1.1.

    I tried following this guide but it fails with the error message below: https://forum.pfsense.org/index.php?topic=54029.0

    Error Message:

    starting: Tue Apr 1 17:07:58 PDT 2014

    svn: warning: '10.22.0.2' is already under version control
    Added 10.22.0.2

    Trying to get all of the configs.
    10.22.0.2 clogin error: Error: Couldn't login: 10.22.0.2
    10.22.0.2: missed cmd(s): dir /all slavedisk2:,show rsp chassis-info,show capture,dir /all sec-slot2:,show diag,dir /all disk1:,show gsr chassis,dir /all sec-nvram:,show diag chassis-info,dir /all disk2:,show running-config view full,dir /all sec-bootflash:,show spe version,dir /all slaveslot2:,dir /all disk0:,show install active,show bootvar,dir /all slaveslot0:,dir /all sec-slot1:,dir /all harddiska:,dir /all slavenvram:,show flash,dir /all sec-disk2:,dir /all slavesup-bootflash:,dir /all sec-disk0:,dir /all harddiskb:,show variables boot,show boot,show inventory raw,dir /all slavedisk1:,show env all,show module,show shun,show controllers,show diagbus,more system:running-config,dir /all slavedisk0:,show debug,show idprom backplane,dir /all bootflash:,dir /all sup-bootdisk:,dir /all sec-slot0:,dir /all sec-disk1:,write term,show vtp status,dir /all sup-bootflash:,dir /all slot2:,dir /all harddisk:,dir /all slot0:,dir /all sup-microcode:,show vlan,dir /all slavebootflash:,show controllers cbus,dir /all slaveslot1:,dir /all nvram:,show version,show vlan-switch,show redundancy secondary,show running-config,show c7200,dir /all slot1:
    10.22.0.2: End of run not found

    I created a rancid user on my pfsense box, downloaded the rancid-compat file, updated my .tcshrc file with the following:

    set prompt="%{\033[0;1;33m%}[%{\033[0;1;37m%}cat /etc/version%{\033[0;1;33m%}]%{\033[0;1;33m%}%B[%{\033[0;1;37m%}%n%{\033[0;1;31m%}@%{\033[0;1;37m%}%M%{\033[0;1;33m%}]%{\033[0;1;32m%}%b%/%{\033[0;1;33m%}(%{\033[0;1;37m%}%h%{\033[0;1;33m%})%{\033[0;1;36m%}%{\033[0;1;31m%}:%{\033[0;0;0m%} "

    set prompt="pfsense# "
    set autologout="0"
    set autolist set color set colorcat
    setenv CLICOLOR "true"
    setenv LSCOLORS "exfxcxdxbxegedabagacad"

    exec /home/rancid/bin/rancid-compat
    exit 0

    ===

    My router.db file looks like this:

    10.22.0.2:cisco:up

    ===

    The tail end of my .cloginrc file looks like this. I created a rancid user for the rest of my network equipment and RANCID works fine for them, but it fails on PFSense.

    CMHOME

    add autoenable 10.22.0.2 1
    add noenable 10.22.0.2
    add method 10.22.0.2 {ssh}
    add user        * rancid
    add identity    * $env(HOME)/.ssh/id_rsa

    add password    *              blah
    add user    * rancid
    add method  * {ssh}
    add identity    * $env(HOME)/.ssh/id_rsa

    –-

    I also tried (without the changes above) using the contrib packages (from ftp://ftp.shrubbery.net/pub/rancid/contrib/) and changing my device type in my router.db file to "m0n0", changing my local prompt on the pfsense FW to "pfsense# ", to no avail. I get a blank config file with the following in my logs:

    starting: Tue Apr 1 17:24:31 PDT 2014

    svn: warning: '10.22.0.2' is already under version control
    Added 10.22.0.2

    Trying to get all of the configs.

    Getting missed routers: round 1.

    Getting missed routers: round 2.

    Getting missed routers: round 3.

    Getting missed routers: round 4.

    Sending        router.db
    Transmitting file data .
    Committed revision 165.

    ending: Tue Apr 1 17:24:37 PDT 2014


Log in to reply