Squid tcp_outgoing_address



  • hello every1,

    i am using squid 2.7.9 on pfsense 2.1 with multiple WANs.

    i want squid to use not the default gateway but a different wan.
    using the squid custom-configuration:```
    tcp_outgoing_address "WAN2 IP"

    but my problem is, that the ip of WAN2 changes every 24 hours.
    is there any opportunity of telling squid to use a specific interface instead of IP - address?
    
    i appreciate any help!


  • Did you have any solution for this? Facing the same problem at the moment.



  • no :-(

    i did the following workaround:

    set the default gateway to the interface, which u want squid to use. after that, i forwarded all other traffic over the other wan thru firewalls rules.

    works for me.



  • @user1378:

    hello every1,

    i am using squid 2.7.9 on pfsense 2.1 with multiple WANs.

    i want squid to use not the default gateway but a different wan.
    using the squid custom-configuration:```
    tcp_outgoing_address "WAN2 IP"

    but my problem is, that the ip of WAN2 changes every 24 hours.
    is there any opportunity of telling squid to use a specific interface instead of IP - address?
    
    i appreciate any help!
    

    Hello,

    have you set some particular setting on squid to get this working?
    I have done lots of tests, but i always see that squid only uses the default router, and ignores the secondary wan…unless you set the "allow default gateway switching" on the advanced tab.
    If that box is checked, and the default gateway is down, the traffic is correctly routed to the second wan.

    I would like to be able to route a specific client/subnet through the secondary link, even if the primary is up (active/active configuration).

    Is there any way to get this working?

    Edoardo