PfSense instalado no virtualbox não tem acesso a internet



  • Eu tenho o seguinte cenário:

    Real:

    • Roteador wireless com acesso a internet através de um provedor

    • Notebook com Win7 e Virtualbox, com acesso a internet através do roteador

    • IP do roteador 192.168.1.1 e do notebook 192.168.1.100

    Virtualbox:

    • pfSense com duas placas de rede, uma em modo bridge (em0) e a outra em rede interna (em1)

    • A em0 foi definida para wan e com o IP 192.168.1.254, fazendo parte da rede do roteador e da máquina real

    • A placa em1 está configurada para a LAN e com IP 192.168.10.1

    • Na LAN, os IPs são distribuídos por DHCP

    • Na outra VM foi instalado o Ubuntu, obtendo o endereço automático 192.168.10.2

    Vamos ao problema. Consigo acessar normalmente o pfSense pelo browser no Ubuntu, mas não consigo acessar a internet. Fiz um teste de ping pelo pfSense, este está se comunicando com o roteador (192.168.1.1) e o Ubuntu (192.168.10.2), mas não consegue se comunicar com a internet e nem com a minha máquina real. O Ubuntu consegue se comunicar com o pfsense (192.168.10.1), mas com o restante não.

    Qual é a solução? Roteamento? NAT? Gateway?

    Obrigado!



  • confira se a a placa WAN esta realmente funcionando, pois o ping que vc esta rodando pode estar indo pela LAN, na duvida, tcpdump nela, se estiver tudo OK, verifique se o gateway de sua WAN é o ip do seu router e se o router nao tem um firewall bloqueando a saida



  • da uma olhada no fiewall do w7



  • Configurei o NAT e o Gateway. Fiz o teste e não funcionou.

    Depois reiniciei o servidor e a máquina real, e quando me conectei à internet, funcionou perfeitamente!

    Estou criando um tutorial explicando todos os passos, quando terminar posto aqui.



  • Olá,
    Estou com o mesmo problema se tiver como você posta como resolveu seria de grande ajuda.
    Obrigado!