Regra de cache não funciona, me ajudem.



  • Boa tarde, eu tenho em uma clinica o pFsense 2.1 instalado, com squid 2.7 instalado fazendo cache.
    Lá temos um sistema que o seu armazenamento aplicativo e banco fica em cloud, e sempre que há atualização , é feito de forma automática quando se inicia o sistema, ele verifica a versão e informa que tem um atualização e dá a opção de fazer o download e atualizar. Só que o aplicativo acaba ficando em cache, só que quando tem uma nova atualização, não surge para a rede pois ainda usa  cache. Eu já tentei desabilitar o cache para ver se resolve, criei regra em rules>lan liberando a porta que usa, mas não consigo corrigir isso, alguém pode me ajudar?

    Este é o endereço que vejo as versões e que é usado pelo aplicativo para fazer as atualizações, http://homolog.siclim.com.br:8082/lindarosa/fontes/publish.htm

    Só consigo atualizar quando eu apago todo o cache ou retiro as máquinas do proxy.

    Não uso poxy transparente, uso manual setado por GPO. Já coloquei o endereço e ip na opção do not cache do squid e nada. Realmente não sei o que mais fazer, estou com isso a uma semana tentando resolver.



  • Tente não fazer cache desta pagina em cloud.
    No seu squid utilize o campo Integrations e coloque algo assim.

    acl SITES_NO_CACHE url_regex "endereco_site_nao_fazer_cache";
    no_cache deny SITES_NO_CACHE;

    Caso esteja utilizando o squidguardian esta regra acima fica antes da regra de integração com o squidguardian.

    Se vc preferir pode criar uma Target categories no squidguard e apontar a mesma conforme abaixo.
    Desta forma vc administra a lista de sites sem cache via squidguard.
    acl SITES_NO_CACHE url_regex "/var/db/squidGuard/SITES_NO_CACHE/domains";
    no_cache deny SITES_NO_CACHE;



  • gilmarcabral, eu juro que tentei achar este campo integration, mas não conseguir acha-lo.  Meu squid é o 2.7.9 pkg v.4.3.3.
    Eu não estou utilizando o squidguardian, cheguei a instalar mas acabei removendo e deixando o squid puro, eu coloco alguns sites de planos de saúde no whitelist e no blacklist eu coloco um "." para bloquear geral, tudo mesmo. E só libero diretoria a tudo no campo Unrestricted IPs.
    Tenho o lightsquid que ainda não configurei e nem estou usando, mas acho que não possa influenciar, ou pode?

    Pode me auxilia no caminho?

    Obrigado desde já.



  • Não utilizo o squid 2.7.9.
    Tente utilizar uma versão mais nova do squid, um squid3 ou squid3-dev pois na squid 2.7.9 não tem estas opções.
    Caso queira usar mesmo o squid 2.7 você terá que fazer esta personalização no arquivo /usr/local/pkg/squid.inc



  • Se eu colocar a regra dentro do /usr/local/pkg/squid.inc, teria alguma parte entre os códigos que tenho que colocar especificamente?
    Vou tentar colocar outra versão do squid, mas tem que ser um FDS onde não consiga interromper os atendimentos da clinica.



  • antes faça um backup do squid squid.inc.
    Encontre as linhas:
    auth_param basic children
    auth_param basic real
    auth_param basic credentialsttl

    adcione as entradas neste local para testar.



  • O pacote squid2 não tem o campo integration, só o custom options.



  • Marcelo, então eu posso colocar as linhas citadas pelo nosso amigo Gilmar em custom options que vai rodar?



  • @tmartins:

    Marcelo, então eu posso colocar as linhas citadas pelo nosso amigo Gilmar em custom options que vai rodar?

    sim, respeitando a descrição do campo (linhas separadas por ";")



  • Duas dúvidas, a primeira é, em vez de colocar a URL eu posso colocar o IP que vai funcionar da mesma forma?
    outra dúvida é uso as aspas ou não? Exemplo:

    acl SITES_NO_CACHE url_regex "216.245.212.181"; no_cache deny SITES_NO_CACHE;



  • Deve utilizar as apas ""
    Pode ser tanto o IP como o endereço do site.



  • Estive ausente por uns dias, mas de volta a ativa. Como não estava tendo sucesso no squid 2.7, tirei ele fora e coloquei o squid 3.1.20 pkg 2.0.6 na esperança de ser um bug entre o 2.7 e o sistema 2.1, não sei, somente uma suposição. Estou fazendo os teste e amanhã posto o resultado se deu certo ou não.



  • Sem sucesso, não rolou com o novo squid, e inserir as regras em integration e também sem sucesso, o que pode ser?



  • Se você entende de squid,  veja o arquivo de configuração criado pelo pacote.

    Pessoalmente não recomendo o squid3.1, use o squid3.3 no lugar(pacote squid3 - dev.  Aqui no fórum tem tutoriais mostrando como configurar e baixar as bibliotecas necessárias).



  • Marcelo, tenho conhecimentos limitados no squid, e olhando o arquivo do squid, aparece as linhas acima com regra de liberação e nada.
    Vou desistalar o pacote do squid 3.1 então e colocar o 3.3 dev. E fazer um teste.

    Sou novo no pfSense, sempre usei outra distro para fazer meus firewall, mas sób no basicao via linda de comando mesmo.



  • @tmartins:

    Vou desistalar o pacote do squid 3.1 então e colocar o 3.3 dev. E fazer um teste.

    Excelente escolha, meus squids são todos 3.3(pelo menos até o 3.4 aparecer no ports do freebsd).



  • Bom, eu fui fazer um teste, mas o aplicativo está fora do ar, agora só quando acabar o feriodo, e o povo da empresa voltar para pedir para eles disponibilizarem o arquivo de homologação e continuar como o squid 3.3 para ver se resolveu, senão estou lascado. (hehehe)



  • Bom, eu tentei de tudo. Atualizei as versões dos squid, já tentei até mesmo desabilitar o cache, deixei zerado o hd e kb maximo de armazenamento, mas o pfsense continua fazendo cache desse aplicativo e nunca consigo atualizar o problema quando é liberado no servidor.

    Que zica pode ser essa? Bug do pfsense ou do squid?



  • @tmartins:

    Que zica pode ser essa? Bug do pfsense ou do squid?

    Acho que na sua configuração.