Proxy automático "WPAD"



  • Bom dia lista.
    Será que alguém pode me dar uma luz para configurar a detecção do proxy automático.

    Segui esse tuto https://forum.pfsense.org/index.php?topic=53331.0, porém sem sucesso.

    O que acontece é que quando ativo a regra da porta do squid (3128), a estação não reconhece o proxy, mas se eu seto ele na mão funciona perfeitamente.

    Pelo que vi, quando a regra está ativada, " IPv4 TCP LAN net * * 3128 * none"  , o DNS para de resolver.

    Alguma idéia porque?
    Grato.



  • tem varias coisas que podem estar influenciando:

    • se vc acessar http://seu_ip/wpad.dat o que acontece?
    • o DHCP de sua rede é feito pelo PFsense?
    • testou wpad por DNS?

    da uma olhada:  http://www.pfsense-br.org/blog/2013/12/configuracao-wpad-no-pfsense-2-1/



  • Olá Lucas.
    Desculpa pela demora da resposta mas estava em viagem.
    Vamos lá:

    • se vc acessar http://seu_ip/wpad.dat o que acontece?
      consigo fazer o download normalmente

    • o DHCP de sua rede é feito pelo PFsense?
      sim

    • testou wpad por DNS?
      Como faço isso? não entendi sua pergunta muito bem.

    da uma olhada:  http://www.pfsense-br.org/blog/2013/12/configuracao-wpad-no-pfsense-2-1/
    Já dei uma olhada nesse tuto e fiz todos os testes.

    Vou começar a testar agora novamente, tenho a noite inteira e domingo para resolver.
    Qualquer ajuda é bem vinda.



  • Dignei uma dica utilize o DNS para resolver o wpad.
    Coloque o próprio pfsense para ser o dns da sua rede.
    Exemplo nos clientes o servidor dns será o proprio pfsense.
    Configure o DNS forwarder do pfsense para resolver:

    Host = wpad
    Domain = SEU_DOMINIO.COM.BR
    IP address = IP_PFSENSE.

    Acesse uma maquina cliente e tente ver se o comando resolve algo ping wpad.
    Se ele retornar algo e porque o wpad esta funcionando corretamente.
    Basta você colocar o navegador para detectar automaticamente.
    Caso não funcionar verifique se o cliente resolve maquinas no dominio.



  • @gilmarcabral:

    Dignei uma dica utilize o DNS para resolver o wpad.
    Coloque o próprio pfsense para ser o dns da sua rede.
    Exemplo nos clientes o servidor dns será o proprio pfsense.
    Configure o DNS forwarder do pfsense para resolver:

    Host = wpad
    Domain = SEU_DOMINIO.COM.BR
    IP address = IP_PFSENSE.

    Acesse uma maquina cliente e tente ver se o comando resolve algo ping wpad.
    Se ele retornar algo e porque o wpad esta funcionando corretamente.
    Basta você colocar o navegador para detectar automaticamente.
    Caso não funcionar verifique se o cliente resolve maquinas no dominio.

    ou se for windows crie manualmente um host A com nome wpad apontando para o ip do seu pfsense



  • Valeu Gilmar e Lucas.
    Realmente era o DNS mal configurado.

    Vou descrever o que fiz para funcionar:

    Segui esse post http://www.pfsense-br.org/blog/2013/12/configuracao-wpad-no-pfsense-2-1/

    No PF Sense fiz o seguinte:

    System => General Setup => DNS Servers

    desmarque o box "Allow DNS server list to be overridden by DHCP/PPP on WAN"

    Services => DNS forwarder

    marque o box "Enable DNS forwarder" e "Register DHCP static mappings in DNS forwarder"

    Salva e pronto.

    Peço desculpa pela demora das resposta, mas estou trabalhando que nem um louco esse mês graças a Deus.
    Agora preciso resolver a questão da lentidão, pois está demorando para acessar as páginas.
    Se alguém quiser ajudar, agradeço.



  • Sobre a lentidão.
    Você fez o teste com e sem o squid?
    Para você ver se o problema esta no pfsense ou no squid?



  • https://forum.pfsense.org/index.php?topic=69840.msg385643#msg385643

    segue o que eu fiz. hj tenho 3 vlans e todas funcionando com wpad

    grato


Log in to reply