QinQ pls advise



  • Anyone using QinQ, can't believe i'm so unique trying to set it up.
    latest version 2.1.1 doesn't seem to set the outer tag for outgoing frames.
    They are seen with inner tag only and i tested it.

    here is my interface, i want to have ip interface on inner vlan 444 and route it through catalyst with outer vlan 10

    em0_10_444: flags=28943 <up,broadcast,running,promisc,simplex,multicast,ppromisc>metric 0 mtu 1500
            options=28 <vlan_mtu,jumbo_mtu>ether 00:07:e9:0c:49:1f
            inet6 fe80::207:e9ff:fe0c:491f%em0_10_444 prefixlen 64 scopeid 0x9
            inet 10.10.10.1 netmask 0xffffff00 broadcast 10.10.10.255
            nd6 options=1 <performnud>media: Ethernet autoselect (1000baseT <full-duplex>)
            status: active

    and this is what i capture on the em0 interface

    15:44:56.337106 00:07:e9:0c:49:1f > ff:ff:ff:ff:ff:ff, ethertype 802.1Q (0x8100), length 46: vlan 444, p 0, ethertype ARP, Ethernet (len 6), IPv4 (len 4), Request who-has 10.10.10.2 tell 10.10.10.1, length 28

    Please, advise, as there's not much can be done wrong in the settings, are there any tricks?
    In previous version, 2.1, the frames did not leave interface at all, causing output errors.

    Probably, there's older version where QinQ works or any ideas?
    Thanks.</full-duplex></performnud></vlan_mtu,jumbo_mtu></up,broadcast,running,promisc,simplex,multicast,ppromisc>


Log in to reply