Package Install on 2.1.1 after Upgrade



  • I have just updated my amd_64 full install to 2.1.1.  I go the SHA256 chekcksum error but downloaded and updated it manually.

    When I went to go to the packages list it said that it couldn't contact https://packages.pfsense.org

    I use a Squid proxy server on another host.  I tried my previous fix of adding/removing the trailing slash on the proxy URL but that didn't work.

    I went into https://pfsense/pkg_mgr_settings.php and added a check for a custom location and entered:

    http://packages.pfsense.org

    and the package list updated immediately.  looks like there is a problem accessing an HTTPS link for the packages via a proxy server.  I have checked and my management machine can get to the same HTTPS link via the same proxy.

    Some errors that were n the logs:

    php: /pkg_mgr.php: XMLRPC request failed with error 5: Didn't receive 200 OK from remote server. (HTTP/1.0 501 Not Implemented)

    Maybe the site is just down for updating or the packages for 2.1.1 haven't been uploaded yet..



  • I can confirm I ran into this same issue, I however didn't need to have the proxy set, just used it to allow caching.  Since https isn't cached on my Squid setup I just removed it, and problem was resolved.

    The autoupdate firmware check was still able to find updates, and the problem persisted after the 2.1.2 update which was done on my system which had this problem, prior to fixing the issue.

    However its definitely a repeatable scenario that should be resolve in the case where the proxy is required.


Log in to reply