Can't boot from SATA drive on ICH7 controller



  • I have 4 machines all exactly the same:
    Asus P5GC-VM MB
    Intel E2140 CPU
    2GB Corsair DDR2 667
    80 WD SATA HDD
    2x Compaq DE-504 NICs

    None of the machine will boot after installed to the hard drive, as soon as it tries to boot to FreeBSD I get a scrolling register dump(big blur actually as it is moving too fast).  If I install onto an IDE drive it boots just fine.  I have tried putting the controller in "compatible mode" also and it still does the same thing.  It looks like FreeBSD supports the ICH7, and I have done some searching and have only found people having this problem when running a IDE drive and was recommended to switch to a sata drive.  I have followed all the boot troubleshooting on the wiki, and played around with these things for 4 days now trying to get them to work.  I would like to keep using my sata drives since I just bought 4 of them and my MB only has one ide port so if I switched to ide, I would have to get new drives and a cable to work with the mounting of the CD-drive and the HDD.  Anyone have ideas on how to make this work?
    Thanks!



  • Well, from what I read it sounded like the ICH7 controller was supported, but it's not on the HCL….so does anyone have some suggestions on an inexpensive sata controller card that works with pfsense?  I have a couple adaptec 2410s that I just tried and they work fine, but I don't have enough for all 4 machines and these are a little over kill since I wasn't planning on running a raid.
    Thanks


Log in to reply