V2.1.1 - problem installing packages on clean install



  • Yesterday I downloaded the 64b iso and installed in a new vm on esx. All was ok until I tried to install packages. I've tried Snort, pfblocker, open vm tools and get a variety of problems. First attempt of one failed the checksum, but clicking reinstall then passed the checksum, but the install later hung. Some get part way through and complain that inc files are missing and then uninstall. Others attempts at installs or reinstalls start, but then get stuck and just hang; eg open vm tools reinstall goes through first screen, then hangs with this:

    Loading package instructions…
    Custom commands...
    Executing custom_php_install_command()...

    Anyone else having any trouble?

    VM is set as 64b oBSD, 2 cpu cores, 2GB ram, 30gb hdd so plenty of resource.



  • Hi,

    I got problems installing the bash-package as I described in this post: https://forum.pfsense.org/index.php?topic=74555.0
    I installed a pfsense-instance a week or two ago with no problems, the new snapshots are producing failures.



  • Here's what I get installing snort

    Beginning package installation for snort .
    Downloading package configuration file… done.
    Saving updated package information... done.
    Downloading snort and its dependencies...
    Checking for package installation...
    Downloading https://files.pfsense.org/packages/amd64/8/All/snort-2.9.5.6-amd64.pbi ...  (extracting)

    Never completes.



  • Same problem here after updating pfSense. While re-installing Snort the system shows something like "Extracting… (15 %)" and never completes. I closed the window as packages should get installed in the background. I logged in with SSH and saw that another package (blinkled) is already installing and this successfully completed as the daemon installed by the package started to show up as processes. Other packages are still missing and I can't open the Package menu item as it says that packages are still being installed. This stuck behaviour lasted for nearly 24 hours by now.

    The system is an ALIX board with pfSense 2.1 upgraded to 2.1.1. Nanobsd 4g image. Update went fine and the firewall is running so this no critical problem but I would really like to know how to get the background installation finsihed (successfully or not...).

    Can I safely reboot the system, stop the background installation or do I have to re-install from scratch? And if it is possible to stop the background installation, how do I do this? Thanks!
    Edit: I just found the option to clear the package installation lock in Diagnostics -> Backup/Restore. So I can see now that only blinkled and snort got installed and no other package… I remove snort now as I don't need it anymore. I installed it for testing purposes only.



  • TLDR: snort's hash file appears missing or the hashes appear broken depending on version.

    I have the same problem trying to install snort-2.9.6.2-amd64

    The logs claim a checksum error:

    kernel: 568706c02e14da2353ca3e15faaf45cab1fcd7945a08d5121cf9d301eb0\n pbi_add: /root/tmp/apkg_snort-2.9.6.2-amd64.pbi failed checksum, the archive may be corrupt.\n";

    The strange thing is I don't see the file snort-2.9.6.2-amd64.pbi.sha256 listed on https://files.pfsense.org/packages/amd64/8/All/

    Packaging error?

    Additionally, when I download the package files myself for 2.9.6.0 the hashes don't seem to match:

    snort-2.9.6.0-amd64.pbi hashes to

    6B9E3BBD7A77CD63256BCB7902F03F9AAC9FCEFF2E6F5FC06F27DAB4FBCDAB35

    snort-2.9.6.0-amd64.pbi.sha256 contains

    c42b84faa71dd6df8e0314141312f95ec349e235e0e69b5d69b0510be2a7be35

    Uhh… more serious packaging error?

    It seems though the hashes for snort-2.9.5.6-amd64 do seem to match. Anyone know how to install an old version?



  • @orthopteroid:

    The strange thing is I don't see the file snort-2.9.6.2-amd64.pbi.sha256 listed on https://files.pfsense.org/packages/amd64/8/All/

    Packaging error?

    The very old pfSense version, 2.1.1, wasn't using FreeBSD 8.3, but a lower version.
    So, probably the download path, used to load basic FreeBSD packages to complete pfSense packages isn't probably valid anymore.

    Easy and best solution:  get the latest version 2.1.4 and your problems are solved.