SMTP Notifications not working when using SMTPS



  • Hi

    I've just configured SMTP notifications with the following settings:

    • E-Mail server: example.com
    • SMTP Port of E-Mail server: 2525
    • Secure SMTP Connection: Enable STARTTLS
    • From e-mail address: pfsense@example.com
    • Notification E-Mail address: user+info@example.com
    • Notification E-Mail auth username (optional): pfsense
    • Notification E-Mail auth password: secret

    When I save these settings and click the "test SMTP" button it all works fine, but the "Enable STARTTLS" checkbox is unchecked by this.
    Sending a test e-mail via RRD E-Mail Reports for example does not seem to use STARTTLS at all. (I can see this in the mailserver log)

    My guess is that the "Enable STARTTLS" option is not saved correctly. Has anyone else noticed this?

    Is there a way for me to submit a bug report?



  • Is there a way for me to submit a bug report?

    Make sure you can reproduce the sequence that makes the problem, then https://redmine.pfsense.org/


  • Banned

    Also make sure you are using 2.1.1 before reporting anything related to this… ;)



  • Thanks, I submitted a bug report for this issue.


Log in to reply