Nut Package working after hack detailed here



  • pfSense-memstick-2.2-ALPHA-i386-20140407-0319.img
    installed to HDD via easy/quick and standard kernel

    Completed WebUI Wizard with only hostname/timezone change and allow private and bogon networks. Enabled ssh access.

    Install the NUT package:-
    N.B. during my trials I had to disable package signing to allow install.
    System: Advanced: Miscellaneous
    Packages signature - tick (to disable)
    Save
    N.B. if you get “Fatal error: Cannot unset string offsets in /usr/local/www/system_advanced_misc.php on line 175” then please see:- https://forum.pfsense.org/index.php?topic=74753.0

    Then prior to nut setup/configuration ssh into the install.

    Using pfSense 2.1.1 as a guide I added the following directories and links:-

    mkdir /usr/pbi/nut-i386/etc/nut
    mkdir /usr/local/etc/nut
    mkdir /usr/local/libexec/nut
    ln -s /usr/pbi/nut-i386/local/libexec/nut/* /usr/local/libexec/nut/
    ln -s /usr/pbi/nut-i386/local/lib/libupsclient.* /usr/local/lib/
    ln -s /usr/pbi/nut-i386/local/sbin/snmp* /usr/local/sbin/
    ln -s /usr/pbi/nut-i386/local/sbin/ups* /usr/local/sbin/

    Services:NUT - Nut Settings tab
    configure you ups setup eg:-
    UPS Monitoring = Local UPS
    Local UPS Name = ups
    Local UPS Model = MGE UPS SYSTEMS Evolution (for serial and mge-shut)
    Local UPS Port = cuaU0 (usb-to-serial adapter used)
    Change button

    N.B. the config files should now have been created in:- /usr/pbi/nut-i386/etc/nut
    but their respective links are missing in /usr/local/etc/nut
    Although I could have linked the directory /usr/local/etc/nut -> /usr/pbi/nut-i386/etc/nut
    that is not the arrangement in 2.1.1, the files are individually linked so:-

    ln -s /usr/pbi/nut-i386/etc/nut/* /usr/local/etc/nut/
    ln -s /usr/pbi/nut-i386/local/etc/nut/cmdvartab /usr/local/etc/nut/

    Services:NUT - Nut Settings tab
    Change button

    NUT should now be working.

    I hope this helps with patching the nut package / package system.


Log in to reply