Endless reboot loop on configuring WAN interface



  • I had a quite simple install done with pfSense-memstick-2.1.1-RELEASE-amd64-20140401-1521 which worked well for a few days.

    It is a FW+NAT with the only "special" config being that the WAN side has a VLAN.

    I then downloaded the pfSense-Full-Update-2.2-ALPHA-amd64-20140406-0758.tgz and updated. Everything went smoothly and ran fine before reboot. Dashboard reported 2.2-ALPHA on 8.3-STABLE.

    I then rebooted and the server went into a reboot loop after pausing for several seconds (this is normal) on "Configuring WAN interface…"

    I then proceeded with a fresh install with the image pfSense-memstick-2.2-ALPHA-amd64-20140406-2034, but I got the same result.

    Had to do a fresh install of the original image.

    I am guessing some VLAN issue?



  • The LAN card in question, a fairly recent PCIe gigabit card of non-brand origin, failed yesterday. It would happily give out some DHCP leases and act normaly towards the OS, but dropped all incoming packets including ping. Replacing it with an identical card solved these problems. I have not tried installing 2.2 yet, will try again as soon as time permits.



  • Installed latest.tgz from 17th of April. Reboot goes ok now (with a new LAN card of same make and model as the faulty one, see above). But I get a lot of error messages in the logs. This is perhaps to be expected from an alpha release. A few examples:

    system[288]: [WARNING] The maximum number of processes has been reached. Please review your configuration and consider raising 'process.max'

    pfsense_interface_rename expects parameter 1 to be string, array given on /etc/inc/interfaces.inc line 3393
    (creating the _stf-interface/6rd-gateway fails.)

    php: rc.bootup: The command '/usr/sbin/pw userdel -n 'admin'' returned exit code '1', the output was 'pw: entry inconsistent pw: gr_copy(): Invalid argument'

    dhcpleases: kqueue error: unkown



  • The first 3 are known,

    1st is to be ignored.
    2nd is fixed in new snaps.
    3rd is to be solved but will see yet the best way.

    dhcpleases one never seen or reported.
    Is unbound or dnsmasq not running?



  • Upgraded with latest snap right now and the wan_stf problem (array error message) is still there.

    Installed in vmware this time, and also got this:

    filterlog: 3,16777216,,1000103491,vmx1,match,block,in,2,bad-len=0,2

    (vmx1 is the LAN interface)



  • Upgraded to the latest snap right now and pfSense enters endless reboot-loop on Configuring WAN interface…kldstat: can't find file if_stf: No such file or directory

    Had to revert to previous snapshot in vmware. The network adapter has driver VMXNET3. There is no VLAN defined in pfSense (vmware handles the VLAN). There is 6RD defined on the WAN.



  • While 6rd does not work yet (see other reports and posts, effectively boiling down to https://redmine.pfsense.org/issues/2882), setting up the 6rd config on wan does no longer cause spontaneous reboots. This thread can be retired.