Random "router may not support IP fragment packets" error



  • I am completely lost with this one and I am hoping that someone can help.

    I have a PS3 and a PS4 and yes I followed the instructions about setting the static option on the outbound NAT rules.  For this problem I have just been testing with the PS3 and when I do an Internet Connection Test The system will tell me that I am using NAT Type 2 which is good but then I will get the error; "The router in use may not support IP fragment packets and some network features may be restricted."  This error will occur about 90% of the time but on rare occasions the test will be successful with no error.  Wait a while and the error will come back.

    Playing around with the "Clear invalid DF" option and disable scrub option seemed to make no difference.  On a side note I never saw this error with the DD-WRT router I used to use.

    Any Ideas?



  • Worth trying to change the MTU on the WAN connection. Normally the box is blank. Try using 1472.



  • The default MTU for my connection is 1500 which I have verified by checking an ifconfig.  I have tried lowering the MTU just to see but it made no difference.  I have also been able to confirm that the 15oo MTU works by installing a base Ubuntu with iptables and linux-igd, there version of UPnP, and everything work perfectly.  I am guessing that this means I have missed some setting in pfSense.


  • Banned

    Are you actually having any REAL problem?



  • That is a fair question.  As far as I can tell the only indication of a "problem" is the gaming devices reporting that my router may not support IP fragmentation and I have only seen this error when using pfSense.  Other than that I am not sure how to "test" to see what is going on.  I was having some issues with game room chats but the problem was so sporadic I chalked it up to the remote servers having issues, suppose that may not be the case.



  • @tlhogan:

    I am completely lost with this one and I am hoping that someone can help.

    I have a PS3 and a PS4 and yes I followed the instructions about setting the static option on the outbound NAT rules.  For this problem I have just been testing with the PS3 and when I do an Internet Connection Test The system will tell me that I am using NAT Type 2 which is good but then I will get the error; "The router in use may not support IP fragment packets and some network features may be restricted."  This error will occur about 90% of the time but on rare occasions the test will be successful with no error.  Wait a while and the error will come back.

    Playing around with the "Clear invalid DF" option and disable scrub option seemed to make no difference.  On a side note I never saw this error with the DD-WRT router I used to use.

    Any Ideas?

    Do you use a Dreytek Vigor by any chance, i had a similar issue and by chance i stumbled accross a solution. Basically i have:

    ADSL connection -> Dreytek Vigor 120 -> pfsense -> LAN

    I noticed issues with my Sky Box whereby the On Demand service wasnt working, nothing i tried helped and while all this was going on the PS4 was giving me that error as well, but i could still do things so i didnt think much about it.

    Then somebody over on the Sky forums said i needed to change my encapsulation on the Dreytek from VC to LLC and try it again, but this would apply to any ADSL modem.

    Not only did it work and my On Demand burst into life, but that error on the PS4 dissapeared as well.

    Like i say, dont know if you have the same setup but its worth a shot.



  • Thanks for the additional ideas.  I have a comcast cable modem, not a DSL service so I ma not sure if this will apply.  I have tried looking around in the modem and I could not find any of the settings that you mentioned.  That could mean that they do not apply or I just do not have access to see them on the customer side.

    At any rate, since I could not get pfSense to completely work with my environment I have stopped using it and I now just have Ubuntu server with iptables running with my own rule set and everything is working fine with that.


Log in to reply