2.2 Firewall Rule description area using a turkish character crashing xml.



  • Test = pfSense-LiveCD-2.2-ALPHA-amd64-20140406-2034.iso
    Issue = Turkish language xml problem

    After the apply turkish language on System > General Setup

    Try add a Firewall rule for using with turkish character.

    Crashing xml system.

    I think solution is Turkish character must be forbidden or All system xml change to charset=UTF-8

    ![turkish character problem1.jpg](/public/imported_attachments/1/turkish character problem1.jpg)
    ![turkish character problem1.jpg_thumb](/public/imported_attachments/1/turkish character problem1.jpg_thumb)
    ![turkish character problem2.jpg](/public/imported_attachments/1/turkish character problem2.jpg)
    ![turkish character problem2.jpg_thumb](/public/imported_attachments/1/turkish character problem2.jpg_thumb)


  • Banned

    @TechnicaL:

    All system xml change to charset=UTF-8

    Yeah… that. Long overdue.



  • Which screen is this?


  • Banned

    It does not matter which screen. You seriously need to stop doing this:

    instead of wasting time on adding yet another bogus sanity checking on input, because, you know, however shocking it may be, there are people using languages other than English and they wish to use non-garbled comments and input in their native language. Recode all the files to UTF-8 w/o BOM, fix the XML, and move on from there. This is a generic issues with the entire pfSense code.



  • @ermal:

    Which screen is this?

    Firewall > Rules > Lan > add new rule

    This is simple, all description area doing that problem.


Log in to reply