V2.1.1 Dansguardian no longer works



  • Hi Everyone

    I upgraded to V2.1.1(i386) this morning and ever since the dansguardian package no longer starts.  Its status is just "stopped" with a red cross next to it.  When i try to start it, it states that "dansguardian has been started" but its status remains stopped. I have tried uninstalling and reinstalling it but that did not work.  Here are some info from the System Log:

    Apr 8 16:12:03 dansguardian[60236]: Error reading file /usr/pbi/dansguardian-i386/etc/dansguardian/lists/blacklists/virusinfected/domains: No such file or directory
    Apr 8 16:12:03 dansguardian[60236]: Error reading file /usr/pbi/dansguardian-i386/etc/dansguardian/lists/blacklists/virusinfected/domains: No such file or directory
    Apr 8 16:12:03 dansguardian[60236]: Error opening file: /usr/pbi/dansguardian-i386/etc/dansguardian/lists/blacklists/virusinfected/domains
    Apr 8 16:12:03 dansguardian[60236]: Error opening bannedsitelist
    Apr 8 16:12:03 dansguardian[60236]: Error opening filter group config: /usr/pbi/dansguardian-i386/etc/dansguardian/dansguardianf1.conf
    Apr 8 16:12:03 dansguardian[60236]: Error reading filter group conf file(s).
    Apr 8 16:12:03 dansguardian[60236]: Error parsing the dansguardian.conf file or other DansGuardian configuration files
    Apr 8 16:12:03 root: /usr/local/etc/rc.d/dansguardian.sh: WARNING: failed to start dansguardian

    Any ideas on how to get it back up and running ??
    Thanks in advance!!



  • I've installed Dansguardian at least twice in 2.1.1… so it's not a "universal" problem... What I'm not sure of is why you're having an issue.

    The error you are seeing indicates that some of the configuration files do not exist. Have you tried re-downloading the blacklists? Also make sure you don't have any blacklists selected (in the config) that don't actually exist on disk (particularly the ones listed - virusinfected). It's possible if you manually applied a config.xml file.



  • Thanks,  downloading new black lists fixed the problem! :)


Log in to reply