Can someone please fix the Snort Package? .pbi files are not on the server



  • The files for the new Snort Package (2.9.6.0 v3.0.5) are not available for anyone on IPv4 but seem to be available to anyone on IPv6. Anyone attempting to update using IPv4 will lose Snort entirely. This is being talked about in a couple other topics, but no one there seems to be able to do anything. I figured I would start a new topic as most of the discussion is in the topic about the new release. Please help!

    I get the following error when trying to update and if I browse to the locations for i386 or amd64, the files are not present:

    Beginning package installation for snort .
    Downloading package configuration file… done.
    Saving updated package information... done.
    Downloading snort and its dependencies...
    Checking for package installation...
    Downloading https://files.pfsense.org/packages/8/All/snort-2.9.6.0-i386.pbi ...  could not download from there or http://files.pfsense.org/packages/8/All//snort-2.9.6.0-i386.pbi.
    of snort-2.9.6.0-i386 failed!

    Installation aborted.Backing up libraries...
    Removing package...
    Starting package deletion for snort-2.9.6.0-i386...done.
    Removing snort components...
    Menu items... done.
    Services... done.
    Loading package instructions...
    Include file snort.inc could not be found for inclusion.
    Deinstall commands...
    Not executing custom deinstall hook because an include is missing.
    Removing package instructions...done.
    Auxiliary files... done.
    Package XML... done.
    Configuration... done.
    Cleaning up... done.
    Failed to install package.

    Installation halted.

    Upon investigation the files are not present @ files.pfsense.org/packages/8/All/snort-2.9.6.0-i386.pbi or files.pfsense.org/packages/amd64/8/All/snort-2.9.6.0-amd64.pbi





  • It is thank you! Although there now appears to be a problem with the Emerging Threats Open rule set, specifically one of the rules in "emerging-web_client.rules" that is causing a fatal error and preventing Snort from starting. I have disabled those rules for now.


Log in to reply