Siproxd package



  • Okay, I know it's early days for packages, but this does not seem a package error, but a .PBI signing issue. Anyway, maybe this is useful to know.

    On pfSense-memstick-2.2-ALPHA-amd64-20140406-2034 the siproxd doesn't load. Error message:

    Beginning package installation for siproxd .
    Downloading package configuration file… done.
    Saving updated package information... done.
    Downloading siproxd and its dependencies...
    Checking for package installation...
    Downloading https://files.pfsense.org/packages/10/All/siproxd-0.8.0-amd64.pbi ...  (extracting)
    ERROR: No digital signature! If you are SURE you trust this PBI, re-install with --no-checksig option.
    of siproxd-0.8.0-amd64 failed!

    Installation aborted.Removing package...
    Starting package deletion for siproxd-0.8.0-amd64...done.
    Removing siproxd components...
    Tabs items... done.
    Menu items... done.
    Services... done.
    Loading package instructions...
    Include file siproxd.inc could not be found for inclusion.
    Removing package instructions...done.
    Auxiliary files... done.
    Package XML... done.
    Configuration... done.
    done.
    Failed to install package.

    Installation halted.

    Thanks for the work on 2.2. I had a computer waiting for it...

    Richard



  • There's an option in Avanced settings to turn off the package signature check, maybe that will help.



  • Thanks for the tip. It would probably help, at least for now, but….

    If I check the box and click save, the gui crashes with this error message:

    Fatal error: Cannot unset string offsets in /usr/local/www/system_advanced_misc.php on line 175

    I tried to see if the option was activated anyway (by installing siproxyd) but it still complained. So at the moment this does not work.

    Richard



  • Fatal error: Cannot unset string offsets in /usr/local/www/system_advanced_misc.php on line 175
    

    That code has been (hopefully) fixed by some recent commits in GitHUb main branch. So it should be in the latest or next snapshot to build.



  • i have trying this version however during the installation of packages of squid 2.7 and squid-guard. error occured

    ERROR: No digital signature! If you are SURE you trust this PBI, re-install with –no-checksig option.

    below is the complete error
    SQUID 2.7 ERROR

    Beginning package installation for squid .
    Downloading package configuration file… done.
    Saving updated package information... done.
    Downloading squid and its dependencies...
    Checking for package installation...
    Downloading https://files.pfsense.org/packages/10/All/squid-2.7.9_4-i386.pbi ...  (extracting)
    ERROR: No digital signature! If you are SURE you trust this PBI, re-install with --no-checksig option.
    of squid-2.7.9_4-i386 failed!

    Installation aborted.Removing package...
    Starting package deletion for squid-2.7.9_4-i386...done.
    Removing squid components...
    Tabs items... done.
    Menu items... done.
    Services... done.
    Loading package instructions...
    Include file squid.inc could not be found for inclusion.
    Deinstall commands...
    Not executing custom deinstall hook because an include is missing.
    Removing package instructions...done.
    Auxiliary files... done.
    Package XML... done.
    Configuration... done.
    done.
    Failed to install package.

    Installation halted.

    SQUID-GUARD ERROR

    Beginning package installation for squidGuard .
    Downloading package configuration file… done.
    Saving updated package information... done.
    Downloading squidGuard and its dependencies...
    Checking for package installation...
    Downloading https://files.pfsense.org/packages/10/All/squidguard-1.4_4-i386.pbi ...  (extracting)
    ERROR: No digital signature! If you are SURE you trust this PBI, re-install with --no-checksig option.
    of squidguard-1.4_4-i386 failed!

    Installation aborted.Removing package...
    Starting package deletion for squidguard-1.4_4-i386...done.
    Removing squidGuard components...
    Tabs items... done.
    Menu items... done.
    Services... done.
    Loading package instructions...
    Include file squidguard.inc could not be found for inclusion.
    Deinstall commands...
    Not executing custom deinstall hook because an include is missing.
    Removing package instructions...done.
    Auxiliary files... done.
    Package XML... done.
    Configuration... done.
    done.
    Failed to install package.

    Installation halted.


  • Netgate Administrator

    And you have turned off the package signature check?

    Steve



  • I just installed the latest AMD64 snapshot 'pfSense-memstick-2.2-DEVELOPMENT-amd64-20140414-0550' and the problem with enabling the option to ignore packet signing has indeed gone away. works fine.

    I could now install the siproxd package, but whatever I tried, I could not get it to work. The log kept indicating: 'siproxd installed, but not running. redirect rules not updated' (or something close to that).

    I seem to have found a way to do without the siproxd package (used a stun server), so I have given up to find a solution for the problem.

    Thanks for all the work on 2.2. Even at this stage, most things I've tried worked perfectly!

    Richard


  • Rebel Alliance

    The "exact" error msg is:

    
    php-fpm[258]: /rc.filter_configure_sync: Sipproxd is installed but not started. Not installing redirect rules.
    
    

    ;)



  • That error message is misleading. The real problem is more like this:

    [2.2-ALPHA][root@redacted]/tmp(32): uname -a
    FreeBSD redacted 10.0-STABLE FreeBSD 10.0-STABLE #32 e852cd6(HEAD)-dirty: Fri May  9 08:34:10 CDT 2014     root@pf22-i386-snap:/usr/obj.i386/usr/pfSensesrc/src/sys/pfSense_wrap.10.i386  i386
    [2.2-ALPHA][root@redacted]/tmp(34): grep sbin /usr/local/etc/rc.d/siproxd.sh
    /usr/pbi/siproxd-i386/sbin/siproxd -c /usr/pbi/siproxd-i386/etc/siproxd.conf &
    [2.2-ALPHA][root@redacted]/tmp(35): file /usr/pbi/siproxd-i386/sbin/siproxd
    /usr/pbi/siproxd-i386/sbin/siproxd: ERROR: cannot open `/usr/pbi/siproxd-i386/sbin/siproxd' (No such file or directory)
    

    So first of all, the start/stop script references a file that does not exist. But there's still a bin folder in /usr/pbi/siproxd-i386:

    [2.2-ALPHA][root@redacted]/tmp(36): file /usr/pbi/siproxd-i386/bin/siproxd
    /usr/pbi/siproxd-i386/bin/siproxd: ELF 32-bit LSB executable, Intel 80386, version 1 (FreeBSD), dynamically linked (uses shared libs), for FreeBSD 10.0 (1000510), not stripped
    

    Which is nice, except:

    [2.2-ALPHA][root@redacted]/tmp(37): /usr/pbi/siproxd-i386/bin/siproxd
    Illegal instruction (core dumped)
    

    Eeep.

    And this is where my journey ends. I'm familiar with strace, but I guess I'd have to dtrace, and I don't know how to dtrace. ;)

    //edit:

    Workaround:

    • Disable Checksum checking, install the current siproxd package

    • Log into the firewall as root.

    
    /etc/rc.conf_mount_rw
    cd /tmp
    fetch http://files.pfsense.org/packages/10/All/siproxd-0.7.2_2-i386.pbi
    #(or fetch http://files.pfsense.org/packages/10/All/siproxd-0.7.2_2-amd64.pbi if you are on am64)
    pbi_add --no-checksig -f siproxd-0.7.2_2-i386.pbi
    sed -i 's/sbin/bin/g' /usr/local/etc/rc.d/siproxd.sh
    
    
    • Save the config of siproxd via web interface. This generates the config without which siproxd won't start

    • Start the service

    • remount ro (if needed)

    
    /etc/rc.conf_mount_ro
    
    

    //edit2:

    Actually, that doesn't work well either. In /usr/pbi/siproxd-i386/etc/siproxd.conf:

    plugindir=/usr/pbi/siproxd-i386/lib/siproxd/
    

    Which is nice, except:

    [2.2-ALPHA][root@redacted]/usr/pbi/siproxd-i386(32): find /* -iname plugin_logcall.la
    /usr/pbi/siproxd-i386/local/lib/siproxd/plugin_logcall.la
    
    

    So, now I'm definitely giving up (read: using a softphone for a while). There is something broken at several points in the packages, both in 8.0 and 7.2.2



  • Ive just installed the siproxd package and it appears to be working.

    Ill update if I have any issues…

    :)



  • As the OP: Thanks for revisiting this old thread.

    Due to a firmware update for the SIP device I was using, it is now aware that's it's behind a firewall and I don't need the siproxd package anymore.
    But as others probably will: thanks for the update.

    Richard


Log in to reply