Squid/Transparent Proxy



  • I am trying to setup the proxy plug-in (squid) as a transparent proxy and I am able to configure it to use an upstream proxy (dansguardian), but the pfsense proxy is only hitting the upstream proxy once any ideas?

    If I setup a computer to use the upstream proxy directly (of course that computer is not behind the pfsense firewall), it works fine, so I am pretty confident that it isn't a problem upstream



  • I have read in this forum about some other oddities in the squid package, is it possible that my problem is related?  Does anyone have the upstream proxy working correctly with 1.2R3?



  • @roe1234:

    I have read in this forum about some other oddities in the squid package, is it possible that my problem is related?  Does anyone have the upstream proxy working correctly with 1.2R3?

    use telnet/ssh login the server,then choice "shell" function, modify the /usr/local/pkg/squid.inc, search {$settings['proxy_port']} {$settings['icp_port']} and adding no-query behind, notice must keep all word in one line, save and you can use the upstream function.

    the key word is no-query, you can read the squid error log, hope auther can correct the problem.


Log in to reply