[Resolvido] NAT com Multiwan



  • Pessoal, gostaria de pedir mais um help! hehe

    Estou com um problema aqui, tenho um Multiwan com loadbalance/failover no meu pfSense, os dois links são:

    Link 1: 2mbps / IP: Fixo (Link da Oi, DMZ para o pfSense)
    Link 2: 10mbps / IP: Variavel (net virtua da vida)

    Acontece que eu tenho um DVR também (equipamento que recebe o sistema de cameras da empresa, Giga Security GS 16480E.) e eu gostaria de poder acessar esse dvr através do meu link de ip fixo.

    Fiz um Port Forward para tudo que chegasse na WAN1, portas TCP 8081, 100 e UDP 9000 fosse repassado para o DVR (IP Local final .90), no entanto quando eu tento acessar pelo IP ele parece não estar encaminhando para o DVR.
    Eu pesquisei varios artigos sobre, mas não sei se eu não to sabendo fazer direito ou se realmente tem algum outro problema por aqui.

    Alguem poderia dar uma mão?

    Anexo print das regras e do NAT.

    Por qualquer ajuda, muito obrigado! :)
    ![nat portforward.PNG](/public/imported_attachments/1/nat portforward.PNG)
    ![nat portforward.PNG_thumb](/public/imported_attachments/1/nat portforward.PNG_thumb)
    ![fw rules.PNG](/public/imported_attachments/1/fw rules.PNG)
    ![fw rules.PNG_thumb](/public/imported_attachments/1/fw rules.PNG_thumb)
    ![fw rules 2.PNG](/public/imported_attachments/1/fw rules 2.PNG)
    ![fw rules 2.PNG_thumb](/public/imported_attachments/1/fw rules 2.PNG_thumb)



  • Pessoal,
    Ninguém se arrisca? hehe :(



    • Sua regra da wan permite todo e qualquer trafego. Isso é muito perigoso.

    • Você precisa monitorar com o tcpdump todas as interfaces para ver para onde os pacotes estão indo.

    • Regras na wan em 99.9% das vezes não tem gateway marcado.



    • Sim, a principio eu preciso saber o que funciona e o que não funciona, se agora que eu não apliquei regra nenhuma tá díficil de descobrir a pane, imagine se eu já estivesse com várias hehe

    • Fiz isso, mas não consegui identificar se o pfsense está recebendo os pacotes, o engraçado é que tem um DMZ pra ele, cogitei a possibilidade de ser pane no modem ADSL, me recomendaram no forum intenacional a fazer um modo bridge, ainda não testei! ;) De qualquer forma, eu queria uma opinião sobre esses port forwarding que eu criei também, porque não tenho certeza se estão refletindo o que eu quero que aconteça

    • Então, acontece que se eu tirar o Gateway ele para de funcionar, não sei se voce se lembra, que postei sobre o load balance uns dias atrás. Eu tenho marcado como GW padrão um GW que não é esse link, e se deixar sem GW Padrão lá no routing, as coisas param de funcionar também, enfim, mas esse é outro problema, e fica pra depois! :D

    Obrigado.



  • gateway nas regras da wan provavelmente é seu problema.

    Colocar o modem em modo bridge é a melhor opção.

    Nos tutoriais aqui do fórum, explica como usar o tcpdump via console/ssh.



  • @marcelloc:

    gateway nas regras da wan provavelmente é seu problema.

    Colocar o modem em modo bridge é a melhor opção.

    Nos tutoriais aqui do fórum, explica como usar o tcpdump via console/ssh.

    Marcelloc,
    Removi os Gateways como você indicou e fiz o modo bridge, funcionou corretamente.
    Agora quando eu entro no meu ip fixo ele redireciona direto pra tela de login do pfsense, tentei criar uma regra bloqueando isso na WAN, aparentemente não funcionou. A questão do redicionamento pro DVR parece estar Ok.

    Alguma sugestão?

    Obrigado pela ajuda! ;)



  • Desabilita o web gui redirect em system advanced e muda a porta do pfsense para qualquer uma diferente de 80 e 443



  • Maravilha cara! Todas as panes sanadas!
    Muitíssimo obrigado! :D


Log in to reply