Clamdscan not working under Dansguardian 2.12.0.3_2



  • I'm running pfSense 2.1.1 and reinstalled Dansguardian package 2.12.0.3_2. When I try enabling clamdscan, Dansguardian refuses to start complaining that:

    Unable to load plugin config /usr/pbi/dansguardian-i386/etc/dansguardian/contentscanners/clamdscan.conf

    .

    And also:

    cs_plugin_load() returned NULL pointer with config file: /usr/pbi/dansguardian-i386/etc/dansguardian/contentscanners/clamdscan.conf

    .

    And

    dansguardian -v

    shows that

    '–disable-clamd'

    , which I thought the built should have

    '–enable-clamdscan'

    .

    Is there something wrong with the package or am I missing something?



  • Hi All,

    I am having the exact same issue as torsurfer. I fear that people are reading through the installations / upgrades - and may not get to see torsurfer's post.

    Before upgrading pfsense to 2.1.2 from 2.1.1. I updated all the packages. DG was resinstalled, and failed to start with:

    Unable to load plugin: /usr/pbi/dansguardian-amd64/etc/dansguardian/contentscanners/clamdscan.conf
    cs_plugin_load() returned NULL pointer with config file: /usr/pbi/dansguardian-amd64/etc/dansguardian/contentscanners/clamdscan.conf

    With DG not starting i decided to upgrade to pfsense 2.1.2 anyway. My analysis is the same as torsurfer. DG seems to be complied / packaged without clamav.

    Regards



  • This seems to be an issue with the newly released dansguardian package… Also being discussed on this thread https://forum.pfsense.org/index.php?topic=58442.msg409913#msg409913.

    Hopefully Marcello is watching this…



  • OK… I was able to get the new DG package working - but only because I had an old install to copy files from...

    Basically, the new version of the package is missing anything relating to the content scanners. I had to copy a bunch of files relating to ipcapscan and clamd into the etc and bin directories. Then I had to create contentscanners directories under dansguardian and dansguardian/lists and copy all of the files from there...

    Bottom line - as far as I can tell it's pretty broken. I can't come up with an easy way to patch it. Pretty much dependent on Marcello creating a new package.



  • @rjcrowder Yeah, that's pretty much what I'm observing too, but I've stopped short of manually copying bunch of files and mucking around with config files for fear of introducing instability to the system and also it might just complicate future upgrades when the patches are out. For now, I have to live with having no virus scanning on pfSense and depends solely on the antivirus software on the individual PCs.

    Hence, I agree with your assessment — as of now, clamdscan and ipcapscan are pretty much non-functional under the current Dansguardian package version. Hope Marcello and the rest of the pfSense team can get this patched soon.

    Kinda sad with the current situation really, since Dansguardian was working just fine before pfSense was updated to 2.1.1.  :(



  • I know that Marcello has his own repository located at http://e-sac.siteseguro.ws/packages/amd64/8/All/ (from another thread). That repository has multiple versions of the Dansguardian pacakge.  But…I can't seem to get it working using pkg_mgr_settings.php. Every time I enter that address and try to go to the list of packages, the GUI tells me it can't communicate with the repository...

    Anyone have any ideas? If we could get that working - or figure out how to install a package from a file - we could install the older DG package version...



  • See this thread for a workaround on the issues with 2.12.0.3_2 https://forum.pfsense.org/index.php?topic=75243.0



  • The workaround as pointed out by rjcrowder works for me.



  • Hi All,

    I am not too sure whats going on, but with 2.1.3-RELEASE (amd64 - built on Thu May 01 15:52:13 EDT 2014) and the most recent version of Dansguardian, (2.12.0.3_2 pkg v.0.1.9), its evident that DansGuardian has NOT been compiled with ClamAV supprt - yet again.

    When can we expect the package maintainer (marcello?) to compile DG with ClamAv support?

     May  7 15:55:01 <1.3> 192.168.0.3 dansguardian[71977]: Unable to load plugin config /usr/pbi/dansguardian-amd64/etc/dansguardian/contentscanners/clamdscan.conf
    May  7 15:55:01 <1.3> 192.168.0.3 dansguardian[71977]: Unable to load plugin config /usr/pbi/dansguardian-amd64/etc/dansguardian/contentscanners/clamdscan.conf
    May  7 15:55:01 <1.3> 192.168.0.3 dansguardian[71977]: cs_plugin_load() returned NULL pointer with config file: /usr/pbi/dansguardian-amd64/etc/dansguardian/contentscanners/clamdscan.conf
    May  7 15:55:01 <1.3> 192.168.0.3 dansguardian[71977]: cs_plugin_load() returned NULL pointer with config file: /usr/pbi/dansguardian-amd64/etc/dansguardian/contentscanners/clamdscan.conf
    May  7 15:55:01 <1.3> 192.168.0.3 dansguardian[71977]: Error loading CS plugins
    May  7 15:55:01 <1.3> 192.168.0.3 dansguardian[71977]: Error loading CS plugins
    
    


  • I don't want to speak for Marcello, but I got the impression (from some other posts he made on this topic) that he wasn't going to worry about fixing it. It sounds like he is waiting for e2guardian (new project based on dansguardian) to become an official freeBSD package and would focus on it…

    Do the workarounds not fix your problem?



  • yes the workarounds do fix the problem. Restoring all the clamav libraries etc. Except - when you see a new DansGuardian package, you expect it to be compiled with the features you had before?

    Also - from all the various posts about Dansguardian, e2guardian is in the NEXT series of pfSense (2.2) - and IF its approved. I am not sure that it will be made available for the 2.1 repository.

    Its a great step going to an unencumbered license through!



  • Hi RJ,

    Can we expect Dansguardian to be built with ClamD support in the future? Its been a month since torsurfer opened this thread and AFAIK Dansguardian has not yet been compiled with ClamD support.

    DG filtering with AV is a highly desirable feature for me….



  • I don't maintain the package… so not sure...



  • Ok cool - thanks for letting us know RJ.

    Is there some way of notifying Marcello? I am not sure if he is aware, and i am unsure of the procedure / protocol to escalate.

    My intention is to see this to completion. If the authoritative answer is NO, Dansguardian will no longer be compiled with clamAV supprt - thats fine. I can pursue other solutions.

    Regards



  • I suppose you could direct message him and see if he responds. I'm not sure what the protocol is for doing that, but I'd be prepared to help rather than just offering a complaint. Most of the package maintainers are doing this gratis.

    Anyway - let me know if you hear anything. I don't have a freeBSD development environment at the moment, but I've considered setting one up and helping maintain the package… just not sure if he wants or needs any help. I'd really like to see e2guardian as a package for a couple of reasons... First, I think there have been some bug fixes (you can find some of them on the message boards). Second, I think it has a much more permissible license agreement.

    Lastly... maybe you've checked it, but I'm not sure that dg is compiled without clamav support. My impression was that the package was messed up and did not include the clamav executables and config files...



  • Hi RJ,

    In private emails to Marcello (using this forum), Marcello suspected ClamD support was also not being compiled and requested that i contact the coreteam directly. I have not been successful in contacting them. I have tried contacting them via the the forum - but the forum does not recognise the address coreteam or coreteam@pfsense.org. I have also tried emailing coreteam@pfsense.org from my gmail account.

    I know fully understand your previous posts expressing your frustration about the coreteam / package building. I much preferred it when Marcello was building these packages - but obviously i understand that he cant do everything!

    Would you know how i can contact the coreteam and asked them to compile DG with ClamD support?


Log in to reply