2.1.2 Cannot redeclare crypt_data()



  • 2.1.2-RELEASE (i386)
    built on Thu Apr 10 05:23:54 EDT 2014
    FreeBSD 8.3-RELEASE-p15

    Fatal error: Cannot redeclare crypt_data() (previously declared in /etc/inc/crypt.inc:35) in /etc/inc/crypt_acb.php on line 43
    

    Got this on a couple of systems.

    1. Trying to install Cron
    2. When changing Status->System Logs Settings, GUI Log Entries to Display to see more log entries after getting (1)
      and
    3. Deleting an entry from the Service Watchdog list, essentially the same thing in longer form:
    Warning: Missing argument 1 for servicewatchdog_cron_job(), called in /usr/local/www/services_servicewatchdog.php on line 56 and defined in /usr/local/pkg/servicewatchdog.inc on line 51 Fatal error: Cannot redeclare crypt_data() (previously declared in /etc/inc/crypt.inc:35) in /etc/inc/crypt_acb.php on line 43 
    

    and so far the Package Reinstall has not completed on any systems. The first one I did, in the log it installed all packages except the last one, Cron, and after 10 minutes or so I cleared the package lock (Cron should install in 1 minute). Then rebooted to make sure I had a clean start. It had the other packages installed fine. I tried to install Cron and got the above error.

    I can't see /etc/inc/crypt_acb.php in the pfSense repo - I guess it is on my system though, I will have a look at it now…


  • Banned

    NSA gotcha already?  ;D :P

    No such file here.



  • The system has 2 files:
    /etc/inc/crypt.inc
    /etc/inc/crypt_acb.php

    Both have the same functions.

    crypt.inc looks like a genuine thing from the pfSense repo

    crypt_acb.php looks like a bonus - the functions in it do similar stuff, but have quite a few lines of difference.


  • Banned

    I guess it comes with autoconfigbackup package? Get rid of that and see again.


  • Rebel Alliance Developer Netgate

    rm /etc/inc/crypt_acb.php /usr/local/pkg/autoconfig*

    Then update the ACB package to 1.22 from the GUI.


  • Rebel Alliance Developer Netgate

    The package had a version check that wasn't right, it was testing for "1.2" anywhere in the version rather than only at the beginning. It's fixed in the repository now.



  • Yep, that fixed it.
    But I still get /etc/inc/crypt_acb.php installed with AutoConfigBackup (i.e. it came back again), but none of the code does a "require" of it any more, so I guess it is just hanging there unused and hopefully will do no harm.



  • Other installs done since AutoConfigBackup was fixed have installed their packages cleanly (including AutoConfigBackup) and all is well.



  • This bricked one of my boxes.

    Insert rude ramblings about previous comments from pfSense team about packages bricking boxes, and finding out this time it's a 'paid for' and marked stable package.

    Thank you jimp (and pfSense team), for the quick repair instructions, for the one time I didn't download an iso simultaneously, and thank you Google, may you always 'steal' my information, so you may provide me the fastest search result in my time of dis pare.

    (and yes, I realize this was pushed out 'quickly' because of HeartBleed.., and yes, I apologize for not adding any real value to this conversation)

    I hope in time this mystical new framework/system the other Jim is talking about resolves issues like this before someone gets bit..


Log in to reply