Can't update 2.1.1 to 2.1.2, 413 Request Entity Too Large



  • I am trying to update pfSense from release version 2.1.1 to release version 2.1.2 using the manual update option. I am uploading "pfSense-2.1.2-RELEASE-512mb-i386-nanobsd-upgrade.img.gz" (which matches my configuration) downloaded from the official pfSense website. About halfway through the upload, I am redirected to a page that says "413 Request Entity Too Large". I have tried the update using several different browsers / operating systems and I have tried re-downloading the above file from several mirrors, but I have always received the same error.

    What am I doing wrong?



  • I haven't messed around with nanobsd, but I would check if you have any space left on your CF-card (or other memory). Nanobsd images for pfSense keep 2 slices on the card, which both take up free space. With a 512 MB image you are left with 256 MB per slice.. I think.



  • The web GUI reports that my flash disk is 87% used. I do not have any packages installed, and disk usage has been at 87% since I installed the system, so as far as disk usage is concerned, my system is identical to stock. I have not seen any documentation that suggests that the upgrade option is nonfunctional on this configuration, so I have no reason to believe that my disk usage is the cause of the problem.


  • Banned

    What's exactly wrong with the non-manual option? Tried that yet?



  • I have not. Unfortunately, the system is on an internal WAN that does not have full internet connectivity. Is the manual upgrade known to be problematic?



  • Might be similar to this: https://forum.pfsense.org/index.php?topic=74140.0
    and maybe his USB stick workaround will help.


  • Rebel Alliance Developer Netgate

    It's time to give up the 512MB cards and move on to something that isn't cramped…



  • Well, the USB flash drive workaround worked perfectly.

    Was this a special case, or do all 512 MB NanoBSD installs have this problem? If this really is the "normal" behavior, I would recommend removing the update option from these versions entirely, since there is no way to use it without an undocumented hack. Maybe add an option in the advanced section to re-enable it. I realize running pfSense from a 512 MB card is not ideal. I definitely need to upgrade. That being said, if pfSense says 512 MB cards are supported, basic functionality (like updates) should work as advertised. I would much rather have pfSense drop support for 512 MB installs entirely than have to find out the hard way that they don't work.

    In any case, thanks for the help! At the very least, that thread with the fix deserves a sticky. :)


  • Netgate Administrator

    Do you have any/many packages loaded?
    Since the package system switced to using PBIs the space required to run each packages increased considerably.
    2-4GB CF cards are pretty cheap though, take this opportunity to invest in one before the next update cycle.

    Incidentally, and somewhat off topic, some time ago I posited the idea of moving /var to a USB drive in systems with low memory such as the Alix. Freeing up 60MB seems like it would be very useful. A script similar to this ought to take care of it. Any thoughts on that from those who run Alix boards?

    Steve


  • Rebel Alliance Developer Netgate

    Given that the ALIX will be EOL soon and not many platforms are stuck with RAM that low, the era of catering to that limitation is fast drawing to a close… So I wouldn't expect anything like that to make it into the official release.

    Moving /var to anything flash based is asking for trouble, but you're more than welcome to hack it up manually if it helps you in some way.

    CF cards are cheap and better quality for the most part these days, I'm surprised we've kept the 512MB CF images around this long, it is probably past time for them to retire, along with the 9600 baud serial default speed. Once upon a time I argued in favor of keeping them that way by default, but now... not so much.


  • Netgate Administrator

    Yes, 9600bps does seem a little outdated these days.
    I would fully expect that running /var on a flash drive will kill it eventually but I would also expect it to take while on a, say, 2GB stick and they are now very cheap. I guess the issue would be what happens if the drive fails? The script would take care of it on reboot but what would happen before that? A by product of this would also be that logs would be readable after a crash and also easily removed from the box for reading.
    Personally I don't have an Alix box so it's not an issue for me. There have been a number of upgrade failure reports since 2.1 though where memory exhaustion seemed to be the culprit, this mod could help that. I wouldn't expect it to ever be official though.  ;)

    Steve


Log in to reply