Firebox x750e running 2.1…safe to auto-upgrade?



  • I'm running an x750e with v2.1 on it currently because my Dell PowerEdge 860 died and my Dell PowerEdge 2950 ended up being too noisy to keep in this room.  After getting the x750e set up earlier I noticed that the main webGUI page was notifying me of this update.

    Do we have any good/bad reviews on auto-upgrading pfsense on these boxes?



  • I upgrade my boxes all the time.  Most of them remotely…  YMMV.    :)

    If your using a CF card for your image you can always revert back via a console connection.

    Part of my job description where I work is to try and break stuff. Ill usually try anything about once.  :o ;D



  • I upgraded 11 nanoBSD systems in a few hours after 2.1.2 was released. 10 of them across OpenVPN links to remote places, just 1 of them local to me. After the bug with AutoConfigBackup was fixed, al the remaining upgrades went fine, installing all their packages and bringing the OpenVPN back up.



  • Awesome, I'll go ahead and start the upgrade.  Hopefully nothing breaks because I have to leave for work in about an hour and a half. :P


  • Netgate Administrator

    Living on the edge!  ;)
    My home box failed to update the first time I tried using the auto method from the webgui. No idea why. It downloaded the update file then just did nothing. Nothing in the logs to suggest it failed or even tried to update either. Second time (I just hit the update button again) it went though no problems.
    If you're running LCDproc with the hybrid start method you have to either reboot the box again or manually issue the start commands. Not a show stopper.

    Steve



  • Install went fine.  8)

    As for LCDproc, I'm using the dev version and followed your instructions here…

    https://forum.pfsense.org/index.php/topic,7920.msg344513.html#msg344513

    I did have to manually issue the commands to get it going again, to avoid rebooting.


  • Netgate Administrator

    Good to know.  :)

    Steve



  • I just noticed a possible issue now that I'm running the latest pfSense.

    I did do the LED mod which, if I'm correct, has the LED on for link and blink for activity.  When there was activity they would fast blink.  Now they're slow blinking.



  • Fixed it.  Just had to re-fetch those two files and reboot.  The /boot/loader.conf/local file change was still there, the upgrade just wiped those modules.


  • Netgate Administrator

    Ah, interesting. Did the modules load correctly? (dmesg|grep LED) Did you copy the modules back after the update? They don't survive.

    Nice. Typed slower than you fixed.  ::)

    Steve



  • I was a bit disappointed that this 2950 ended up being so loud and hot, but honestly now that I'm running this x750e I staged months ago but never used…I'm starting to realize that it's probably better this way.  Keep pfSense on its own dedicated box rather than in a VM on one of my ESXi hosts alongside other VMs.  Whenever my 860 crashed it took my network and internet connectivity with it.

    I'll keep the pfSense VM on the 860 as a backup in case the firebox fails.


Log in to reply