HE.net Tunnel fails with pfSense 2.1.2



  • Just upgraded to 2.1.2 last night and now my tunnel is broken.

    I see this in the logs:

    php: /interfaces_gif_edit.php: The command '/sbin/ifconfig gif0 inet6 '<ipv4 address="">' '<ipv6 address="">' prefixlen 128' returned exit code '1', the output was 'ifconfig: <ipv4 address="">: bad value'

    where <ipv4 address="">is my WAN ip address and <ipv6 address="">is the tunnel remote ipv6 address

    The message makes sense to me, since inet6 was specified, but an ipv4 address was given. I'm not sure what the command was before though and I don't know enough about FreeBSD configuration to know what that is supposed to be.

    Anybody else having this problem?</ipv6></ipv4></ipv4></ipv6></ipv4>


  • Banned

    No. Post the tunnel configuration screenshots.



  • I just upgraded mine from 2.1 to 2.1.2 last night (closing in on 23 hours uptime right now) and have no problems with my HE.net tunnel either. I'm using various VLANs and the /64 plus /64 slices of the /48 you can request for the VLANs. It all came back up just fine honestly.



  • Here's some screenshots of the GIF interface, the Tunnel interface, and the log output.








  • Ok, so I recreated those settings quite a bit, so don't know if they were exactly what I had after the upgrade. In any case, I wanted to verify that I had things correct and when I went to the example config page for HE.net, I found this: https://doc.pfsense.org/index.php/Using_IPv6_on_2.1_with_a_Tunnel_Broker

    After changing the 'gif tunnel local address' to the IPV6 local address on the GIF and setting IPV6 to None on the interface, I got things working.

    Anyway, I feel like an idiot. Please disregard this thread.


  • Banned

    @adler187:

    After changing the 'gif tunnel local address' to the IPV6 local address on the GIF and setting IPV6 to None on the interface, I got things working.

    Yes, that is how it should be. :)


Log in to reply