DNS Forwarder not working named server

  • Hey folks,
    I'm off work this week so I've been using the time to solve some networking issues that have been on my "todo" list way to long.
    I've done pretty well so far thanks to the great help here in the forums, and now I need to call upon some DNS experts.

    While I'm probably fairly novice in general, its fair to say that DNS vexes me more than anything else….

    Prior to going Microsoft Free late last year, my setup worked quite well. I have a site-to-site VPN that connects two subnets. On my subnet, I ran an Microsoft 2003 DNS server. The remote subnet used PFsense's built in server. On my MS DNS box, I just added a zone and told it the server was the remote PFsense box. On the remote box, I used the forwarder to point back to the MS box. All was bliss.

    I have moved to a setup with named running on OS X Server. That seems to have broken resolution in both directions. When I try and setup a secondary zone on my server that uses the remote PFsense box, it does not work. Likewise, setting the forwarder to look to my server when resolving hosts on my subnet fails.

    worth noting:
    local subnet = nsnet.com
    remote subnet = lynchburg.nsnet.com

    Any thoughts? Do I need to generate keys or something?

    Thanks in advance!

  • Please draw a map of how everything is laid out.  I am having a hard time understanding your exact setup.

  • Good suggestion!
    I've discovered that trying to describe network topography in text is a bit tricky

    Does this help?
    Basically, I have a separate DNS/DHCP server on one side and using PFsense for DHCP/DNS on the other, I'd like lookups to work across the two subnets.

    In looking at this, it might be more confusing that I had planned. The text that is floating over the "LAN" machines on each side is meant to be a general description and has nothing to do with the machines it is floating over… I'm not so good at this

Log in to reply