Only get "Boot…" with i386 memstick 2.2-dev 20140413-1535



  • sudo dd if=pfSense-memstick-2.2-DEVELOPMENT-i386-20140413-1535.img of=/dev/sdb

    boot usb stick (tried 2 different ones) and get no further than:-

    Booting…
    \

    pfSense-memstick-2.2-DEVELOPMENT-amd64-20140413-1534.img boots as expected but tricky for me to continue testing as limited available 64bit hardware.



  • Which hardware this is in?



  • Same "Boot…" out come with all of the following:-
    Note that the backslash was actually a / as in:-

    Booting...
    /

    Acer TravelMate 2312LCi_L (Pentium M 2GB)
    has been working fine for testing snapshots and is 32 bit only

    Dell Dimension 3100C (Celeron 2.8GHz 2GB)
    which can do 64 bit and booted 1534 image but just "Boot..." result with 32 bit on this latest image

    Dell Latitude D610 laptop. (Pentium M 2.0 GHz 512MB)
    has been working fine for testing snapshots and is 32 bit only

    Dell Vostro V220 (Core2Duo E7400 2.8GHz 4GB ram)
    tried for first time with pfsense to fill out this post.

    I believe we need to look at recent build changes to see the problem.
    Hope that helps.



  • Amended subject to reflect newer image test.
    Got a bit further with later images in that they seem to boot now but no vga console.

    Just tried
    sudo dd if=pfSense-memstick-2.2-DEVELOPMENT-i386-20140415-0445.img of=/dev/sdb

    Acer TravelMate 2312LCi_L (Pentium M 2GB)
    Booting…

    followed shortly by boot complete tune.

    Dell Dimension 3100C  (Celeron 2.8GHz 2GB)
    Booting…
    |
    followed shortly by boot complete tune

    Dell Latitude D610 laptop. (Pentium M 2.0 GHz 512MB)
    Booting…

    followed shortly by boot complete tune.

    Dell Vostro V220 (Core2Duo E7400 2.8GHz 4GB ram)
    Booting…

    nothing else.

    This is almost identical behaviour to serial variant of this image in above machines, ie no vga console.



  • sudo dd if=pfSense-memstick-2.2-DEVELOPMENT-i386-20140415-1323.img of=/dev/sdb

    on the following 4 systems I get no vga console with above image, only get:-

    Booting…
    and then either "|" on the 64 bit systems and "-" on the 32 bit systems
    nothing else (ie no text or tune)

    Dell Latitude D610 laptop. (Pentium M 2.0 GHz 512MB 32bit)
    Dell Dimension 3100C  (Celeron 2.8GHz 2GB 64bit)
    Dell Vostro V220 (Core2Duo E7400 2.8GHz 4GB ram 64bit)
    Acer TravelMate 2312LCi_L (Pentium M 2GB 32bit)

    Please note all these systems have worked previously with the memstick images, though it was quite a few builds back now.
    Seems all vga console modules/kernel components not kicking in or not build in any longer.
    Hope this helps.



  • Also got this problem on Intel D865GMC motherboard with Pentium 4 processor. Firstly tried to boot with pfSense-LiveCD-2.2-DEVELOPMENT-i386-20140415-1323.iso

    Done some investigations

    pfSense-LiveCD-2.2-ALPHA-i386-20140409-0901.iso boots well till CDROM initialization, after goes hangup for few minutes with a bulk of scsi-request errors (seems like a bug in cdrom/scsi driver, as I tried to boot from SATA and IDE CDROMs - results were the same), and after resumes as if nothing bad had happened. After boot it works normally.

    pfSense-LiveCD-2.2-DEVELOPMENT-i386-20140413-1535.iso is the first image which introduced boot hanging with "Booting… ". But really system doesn't hang, I percieve it in CDROM drive seeking sounds - looks like real vga driver bug



  • Just check new ones.
    It was using serial console configuration and displaying information there.



  • No "new one" since "New version: Thu Apr 17 10:54:27 CDT 2014"?


  • Rebel Alliance Developer Netgate

    Try again now.



  • sudo dd if=pfSense-memstick-2.2-DEVELOPMENT-i386-20140421-1300.img of=/dev/sdb

    Do we need to specify a block size?  I haven't had to before.

    OK tried again with 2 very different usb sticks in 4 different machines as before:-

    nothing but "Booting…" and then
    "|" or "-" on the same four machines.

    Please appreciate that this is obviously a total show stopper.  There can be no community participation in real hw testing on any 386 vga console variant if non of them boot.
    Bit of a shame really.

    Machines tested on:- as in all previous reports by me in this thread.
    Does anyone else have any luck booting any of the last ten or so i386 builds of any non serial console type on any real hardware.

    Is there something more I can do at this end?


  • Rebel Alliance Developer Netgate

    The problem is that the ISO and Memstick for some reason are defaulting to the serial kernel and not the VGA kernel.

    amd64 doesn't have that problem because we no longer make a serial-only kernel for amd64, it isn't necessary there.

    As a workaround, if you really can't use amd64 and you do have a serial connection on there, boot the iso/memstick while connected to the serial console with a null modem cable, press "i" to enter the installer during boot when prompted, install as usual and pick the Standard Kernel during the install. Once it reboots, it will be running as expected.



  • @jimp That's great thanks; will have to dig out null modem cable for the time being and continue from there.

    Cheers.



  • I have used update for the i386 full version of 2.1.1 and it switched to serial, but I have control via webinterface, so how to switch it back to vga?


  • Rebel Alliance Developer Netgate