[SOLVED] Problem installing 2.1.2 on Intel Tiano



  • Update
    The problem turned out to be me booting from a USB 3 port instead of a USB 2.


    After 2.1.1 got released with support for Intel i345 nics, I decided to give it a new shot at installing it on my server.

    Sadly, the installation gets stuck early during the boot process, as you can see from the attached screenshot.

    The last I see on the dmesg reads:

    ACPI APIC TABLE < INTEL TIANO   >
    

    If I don't boot with option 3 (Boot from USB) but instead boot normally, the boot process moves further, so I guess it's not strictly a hardware issue. Any idea what can it be?
    ![Screen Shot 2014-04-14 at 12.36.52 PM.png](/public/imported_attachments/1/Screen Shot 2014-04-14 at 12.36.52 PM.png)
    ![Screen Shot 2014-04-14 at 12.36.52 PM.png_thumb](/public/imported_attachments/1/Screen Shot 2014-04-14 at 12.36.52 PM.png_thumb)



  • What hardware is this?



  • @Jason:

    What hardware is this?

    It's a Supermicro server (http://www.supermicro.com/products/system/1u/5018/SYS-5018A-FTN4.cfm?parts=SHOW). The processor and SoC is this one: Intel® Atom processor C2758, SoC, FCBGA 1283, 20W 8-Core



  • I have that same board.  Mine has been running fine for a few weeks now.



  • I guess that's good to hear, at least I have some chance.

    Did you use the 64bit USB installer? Choosing the option to boot from USB?

    Do you have any specific settings on your BIOS that might affect this?



  • @pgb:

    I guess that's good to hear, at least I have some chance.

    Did you use the 64bit USB installer? Choosing the option to boot from USB?

    Do you have any specific settings on your BIOS that might affect this?

    No, I installed the 64-bit full version from a USB CD-ROM.  I had originally tried to use an ISO through the IPMI card but hit an issue.  Another user posted how to work around that though; you need to set kern.cam.boot_delay=10000.

    I don't recall changing anything in the BIOS except disabling all the stuff I wasn't using (eg. SATA ports).



  • I was able to get the boot process a bit further down. Now it boots after the ACPI, but I get a "manual root file system specification" prompt, as if it were not finding the hard drive.

    Is there any formatting I need to do prior to the installation?



  • Try setting kern.cam.boot_delay=10000 as suggested in the previous post.



  • I tried it, but I still the the manual root file system prompt.



  • Are you trying to do the memstick install, installing from a USB CD-ROM, or from the IPMI with an ISO?



  • I'm trying a memstick install.

    I'll try an IPMI image, and try to get my hands on a USB CDROM, as I currently don't have one.



  • You're not trying to boot from one of the USB 3.0 ports, are you?



  • @razzfazz:

    You're not trying to boot from one of the USB 3.0 ports, are you?

    Turns out I was. This did the trick. Thank you!


Log in to reply