Can't delete interface



  • Hey together,

    I have a (in my eyes) strange problem: I can't delete a interface that I have created before! So here is what I did:

    • created a new PPPoE interface
    • created a new interface and assigned the PPPoE-if to it

    Then I wanted to remove both.

    • tried to delete PPPoE-if: "Can't delete because it's assigned to an interface"
    • tried to delete the interface in the "interface assignments" tab: there is no "X" to delete it

    So what can I do? I have no idea…

    Thanks and greetings.


  • Banned

    A screenshot of what you created would help… since I cannot make any sense of the description.



  • On pfSense you must have the first interface, which is internally named "wan" and can be assigned to whatever network device you like and you can give it a "friendly name" - e.g. yours is called "DSL".
    Look in /cf/conf/config.xml for "DSL" and "wan" - I expect you will find those together in one of the interface sections.
    I guess you are saying that "DSL" and the selected device are not used any more, and you ant to get rid of them.
    You can shuffle device assignments around to get some other current WAN device on that first entry, rename the friendly name to whatever is good for you, then you would have to re-enter the settings and rules from whatever OPTn the WAN-style interface used to be and put thme on the "real wan" interface.


Log in to reply