System log: firewall



  • Ok, I see no one else seems to have this problem, so it's something specific to my situation or I'm doing something wrong, but what is needed to see entries in the firewall log?

    All other (applicable) logs seem fine, but there are no entries in the firewall log at all and never have been for all the snapshots I've tried so far.

    If I use the console option '10) filter logs' I see lot's of entries scrolling. If I use 'diagnostics > pfInfo' there are lots of packets for what seem to be the correct interfaces for WAN & LAN. pfTop also displays lots of entries.

    Any hints?

    Richard


  • Rebel Alliance Developer Netgate

    It's in the process of being converted to a new log daemon/parser. It's known to be broken currently until all the new code is in place.



  • Ah, thanks.

    Now I see that it WAS reported earlier (april 6)

    Anyway, Ill wait patiently until it does work…  ::)

    Richard



  • Where is this reported or tracked at?

    Any ETA?


  • Rebel Alliance Developer Netgate

    No ETA, there is a ticket somewhere I think. Given that it's still in an early alpha state it's not the highest of priorities but it's definitely being worked on.



  • It should be working fine with latest snapshots now.



  • 2.2-ALPHA (amd64)
    built on Mon Apr 28 16:52:25 CDT 2014

    @ermal:

    It should be working fine with latest snapshots now.

    I'm not sure it does. I still get nothing.
    Should it work with this snapshot?

    Richard


  • Rebel Alliance Developer Netgate

    It was working but had broken again… This morning it appears to be OK. The rule lookup code is fixed in the repo now, the current snapshot will do rule lookups when you click on the action icon, but the row/column description display doesn't work until the commit I pushed a few minutes ago.

    So by the next snapshot (or current snap + gitsync to master) it should be OK all around.