RESOLVIDO - Squid + SquidGuard



  • Bom dia Povo..

    Estou quebrando a cabeça aqui para configurar um squid com squidGuard..

    A situação é a seguinte…

    Meu chefe solicitou que existisse 3 grupos...

    o Dele... rs.. com acesso total a internet..
    o do pessoal admin com alguns bloqueios la no black list
    e o pessoal geral... que acessa apenas os sites do whitlist...
    As autenticações serão feitas por usuarios cadastrados no proprio pfsense

    Configurei o squid (Proxyserver) e ja inseri alguns endereços permitidos... Fiz a configuração padrao..

    No squidguard, aba general informei o black list.. aba common ACL não configurei nada... na aba Groups acl criei a regra do grupo "Usuario_comum" dentro deste informei que seria o usuario "user" ... em target rules informei tudo como WhiteList ...

    Entendo que este grupo deveria acessar apenas a White list... porém.. nao funciona...
    Quando autentico no navegador.. tento acessar qualquer site.. tudo bloqueado.. e o que esta me deixando de cabeça quente.. o erro mostra que este usuario faz parte do grupo "default" o que não era para ser....

    Conseguem me ajudar?

    Segue print de tudo.. como fiz bastante.. esta la no mega...

    https://mega.co.nz/#F!g11AFSTa!yV-3eRIgv30vXCjElgHpyg

    Obrigado...



  • Na aba Common ACL do squidguard clique em Target Rules List em Default access [all] coloque allow



  • Quando faço isso.. todos os sites são liberados…



  • @Felipe:

    Bom dia Povo..

    Estou quebrando a cabeça aqui para configurar um squid com squidGuard..

    A situação é a seguinte…

    Meu chefe solicitou que existisse 3 grupos...

    o Dele... rs.. com acesso total a internet..
    o do pessoal admin com alguns bloqueios la no black list
    e o pessoal geral... que acessa apenas os sites do whitlist...
    As autenticações serão feitas por usuarios cadastrados no proprio pfsense

    Configurei o squid (Proxyserver) e ja inseri alguns endereços permitidos... Fiz a configuração padrao..

    No squidguard, aba general informei o black list.. aba common ACL não configurei nada... na aba Groups acl criei a regra do grupo "Usuario_comum" dentro deste informei que seria o usuario "user" ... em target rules informei tudo como WhiteList ...

    Entendo que este grupo deveria acessar apenas a White list... porém.. nao funciona...
    Quando autentico no navegador.. tento acessar qualquer site.. tudo bloqueado.. e o que esta me deixando de cabeça quente.. o erro mostra que este usuario faz parte do grupo "default" o que não era para ser....

    Conseguem me ajudar?

    Segue print de tudo.. como fiz bastante.. esta la no mega...

    https://mega.co.nz/#F!g11AFSTa!yV-3eRIgv30vXCjElgHpyg

    Obrigado...



  • Para funcionar desta forma.. em common ACL neguei tudo…
    Depois fui em Target Categories e criei uma regra para liberar estes sites/dominios/palavras/... depois fui no Groups ACL e neguei tudo.. apenas liberei a categoria que foi criada em Target Catergories... por ultimo Fui até common e liberei as categorias criadas..

    JA era.. tudo funcionando...

    Valew!!!


Log in to reply