Connect two Routers through WAN [SOLVED]



  • Hello folks,

    I recently installed a pfSense machine in my home lab and I ended up having 2 networks and it's exactly what i wanted but can anyone give me some advises what should I set in the routers so that computers can see each other?
    I know about the routing tables but I need some help…

    That's my network set-up:

    WAN - ISP Router DHCP (192.168.1.254)

    |                                          |
                          |                                          |
                          |                                          |
                          |                                          |

    **              pfSense                        Tomato WRT54GL**

    (WAN: 192.168.1.67)          (WAN: 192.168.1.66)

    (LAN: 192.168.2.1)              (LAN: 192.168.3.1)

    |                                          |
                          |                                          |
                          |                                          |
                          |                                          |

    Lab Network                          Home Network

    Thanks in advance.  ;)



  • pfSense System->Routing. Add a gateway on WAN, 192.168.1.66. Add a route to 192.168.3.1 through that gateway.
    Firewall Rules, WAN - add a rule pass source 192.168.3.0/24 destination LANaddress.

    Then do some similar thing in Tomato.



  • @phil.davis:

    pfSense System->Routing. Add a gateway on WAN, 192.168.1.66. Add a route to 192.168.3.1 through that gateway.
    Firewall Rules, WAN - add a rule pass source 192.168.3.0/24 destination LANaddress.

    Then do some similar thing in Tomato.

    Hi Phil,

    Thanks a lot for the quick answer.
    I did everything you said but I really don't know if I can add a gateway in Tomato, I successfully added a new static routing table on WAN but I can't find anything related to gateway settings except the main WAN port that now is set to DHCP.
    The router at the moment it's in gateway mode, I should change it to router mode or not?
    I'm a bit confused about these settings…Sorry but I'm not good at this stuff! :P
    Hope you can help me to figure it out.

    Thanks for your patience.



  • Sorry for the double post but I played till now with routing tables and firewall settings but still no luck.
    If I understood something this should be correct:

    Tomato 1.28 WRT54GL

    Operating Mode: Gateway

    Static Routing Table:

    Destination        Gateway   Subnet Mask         Metric        Interface            Description
    192.168.2.0 192.168.1.67 255.255.255.0          0             WAN               pfSense

    Startup firewall rules:

    
    iptables -I INPUT -s 192.168.2.0/24 -j ACCEPT
    iptables -I FORWARD -s 192.168.2.0/24 -j ACCEPT
    iptables -t nat -I POSTROUTING -s 192.168.2.0/24 -d 192.168.3.0/24 -j ACCEPT
    

    I tried also to disable the firewall completely using a script that I found and finally from a workstation under pfSense i can ping at least the WAN IP of the Tomato Router but for some reasons using this script I lost the WAN connection…
    I don't know seems that the static routing tables aren't working at all, maybe I should try a different firmware or maybe would be easier to buy another router and using it as gateway between the two networks?



  • Solved with an OpenVPN tunnel :)

    I had hard time to make it work but seems very responsive and stable.