Package Open-VM-Tools installation error



  • Hello!

    I am unable to install the "Open-VM-Tools" package on the latest amd64 snapshot.

     Downloading https://files.pfsense.org/packages/10/All/open-vm-tools-nox11-1280544_4-amd64.pbi ...  (extracting)
     Verifying Checksum...SKIP_ARCHLINES: 65
     Archive checksum: f875797959062d0d30f30a331335c6948dfc4b8cbcdeaf126192c5a765421ed9
     Saved checksum: 686e6d9baeed5b3a0d8a86e052e04b17c42443fbf1c9d30410001e37ef7814cd
     ERROR: /tmp/apkg_open-vm-tools-nox11-1280544_4-amd64.pbi failed checksum, the archive may be corrupt.
    of open-vm-tools-nox11-1280544_4-amd64 failed!
    

    2.2-ALPHA (amd64)
    built on Wed Apr 16 18:14:39 CDT 2014
    FreeBSD 10.0-STABLE



  • Do the following on the pfSense box either the box itself or SSH:

    
    1\. fetch http://files.pfsense.org/packages/10/All/open-vm-tools-nox11-1280544_4-amd64.pbi
    2\. pbi_add --no-checksig -f open-vm-tools-nox11-1280544_4-amd64.pbi
    3\. add the package from the pfSense Web Interface, and it'll install
    
    


  • Thank you, pfSense2User! With this I successfully installed open VM tools.

    However, ESXi still reports that the tools are not installed. pfSense's reboot didn't help the situation.



  • I have the same issue. I also noticed that on upgrade to the latest snap today, I got this in the console:

    Installing Open-VM-Tools and its dependencies.ERROR can't find installed pbi (open-vm-tools-1280544_4-amd64)

    It then proceeds to count 10%,20% etc upwards. So i certainly finds something.

    But still shows as not installed.



  • So I know this is a little late to the thread here, but I am experiencing the same problem with the open-vm-tools package failing on install in the GUI due to "no digital signature".  I was able to force install with pbi_install and the –no-checksig option and verified the install with pbi_info, however  the #3 instruction to attempt install from the gui again fails for the same reason as above.

    Is there anyway to install from the gui with the --no-checksig option?  Or something simple I'm missing here.  Thanks

    *Running pfsense 2.2 on ESXi



  • @joelmale:

    Is there anyway to install from the gui with the –no-checksig option?  Or something simple I'm missing here.  Thanks

    System: Advanced: Miscellaneous: Package settings: Package signature: Do NOT check package signature



  • Exactly what I was missing then, worked like a charm.  Thanks!