Pfsense 2.1.2 amd64 Squid3-dev com c-icap



  • Bom dia.
    Galera comecei os teste do antivirus do squid3-dev.
    Porem quando habilito antivirus a paginas de internet não abre.
    Aparece a seguinte mensagem quando tenta navegar:
    Alguém tem ideia do que pode ser?
    Desde já agradeço

    ERROR
    The requested URL could not be retrieved

    O seguinte erro foi encontrado ao tentar recuperar a URL: http://www.uol.com.br/

    Erro de protocolo ICAP.

    O sistema retornou: [No Error]

    Isto significa que alguma característica da comunicação ICAP falhou.

    Alguns dos possíveis problemas são:

    O servidor ICAP não é alcançável.

    Uma resposta ilegal foi recebida do servidor ICAP.

    Gerado Thu, 17 Apr 2014 14:50:09 GMT por murici2 (squid)



  • Zica do icap no amd64, alguns usuários reportaram que na versão i386 está funcionando bem.



  • Será e a versão do c-icap ou alguma biblioteca?
    Alguma sugestão de como debugar para descobrir a causa?
    Nos logs do c-icap não encontrei avisos de algo anormal.



  • Estou no mesmo ponto, só tenho os alertas do daemon morrendo.



  • Ola…Colei as Seguintes linhas

    icap_enable on
    icap_send_client_ip on
    icap_send_client_username on
    icap_client_username_header X-Authenticated-User
    icap_service service_req reqmod_precache bypass=1 icap://127.0.0.1:1344/squidclamav
    adaptation_access service_req allow all
    icap_service service_resp respmod_precache bypass=1 icap://127.0.0.1:1344/squidclamav
    adaptation_access service_resp allow all

    em "Integrations" e nao apareceu mais a msg

    ERROR
    The requested URL could not be retrieved

    O seguinte erro foi encontrado ao tentar recuperar a URL:

    Erro de protocolo ICAP.

    O sistema retornou: [No Error]

    Isto significa que alguma característica da comunicação ICAP falhou.

    Alguns dos possíveis problemas são:

    O servidor ICAP não é alcançável.

    Uma resposta ilegal foi recebida do servidor ICAP.

    Nao tenho muito tempo pra verificar se realmente esta funcionando.
    se vcs puderem ajudar eu agradeço.



  • O campo integration é separado por ;



  • DioniMH este problema e o que esta ocorrendo nas versão amd64.
    Não coloquei estas linhas integrations e ocorre o mesmo erro que o seu.
    Penso que não precisa informar estas linhas no integratios pois quando habilita o c-icap no squid o mesmo já faz este trabalho.
    Marcello é possível confirmar esta informação?



  • Sim, o pacote já habilita o icap.

    Para tirar a dúvida, basta verificar o arquivo squid.conf após salvar as configurações.



  • Isso mesmo,  estao la as conf referente ao icap.
    Sobre o problema do icap com o squid3-dev amd64 alguma novidade?



  • desenterrando…

    Alguma novidade, pois nesse exato momento estou com esse problema....



  • Ainda sofrendo com isso.  :( Tem alguma novidade sobre correção ou algo do tipo?



  • @jotaherre:

    Ainda sofrendo com isso.  :( Tem alguma novidade sobre correção ou algo do tipo?

    Acredito que as ultimas atualizações do pacote só funcionam na 2.2 ou superior…



  • Uso 2.3.2.p1 e também como o mesmo problema.



  • Estou tendo um erro no i386.

    O estranho que no log peguei isso.

    pid 44410 (clamd), uid 106, was killed: out of swap space

    Memoria
    83% of 863 MiB

    HD
    Disk usage ( / ) 0% of 22GiB - ufs
    Disk usage ( /var ) 8% of 24GiB - ufs
    Disk usage ( /usr ) 4% of 24GiB - ufs

    Efetuei uma redução na memoria utilizada no Squid, vamos ver se o ICAP para de travar…



  • Desenterrando mais uma vez.

    Tenho 2.4.2-RELEASE (amd64) e estou com o mesmo problema.

    Por favor, alguém tem alguma solução?

    Grato!!!



  • Desenterrando o tópico para ajudar quem veio aqui como eu, na dúvida.
    Eu consegui resolver o problema reinstalando os pacotes squid e squidGuard.
    Tinha feito de tudo antes, atualizei o pfsense, reiniciei o Windows Server, mas nada havia solucionado. Somente reinstalando os pacotes consegui a solução.
    Grato,
    Witor Moraes.