PF Sense Limiter slowing the network down



  • Hi All,

    I have a PFSense with latest version 2.1.2

    I have PFSense running inside an ESXI and the Host has only 1 NIC, which is connected to our office Linksys switch on a Gigabit port.

    I have allotted however 3 virtual adapters to the PFSENSE VM and used it for 1 Lan/2x WANs.

    our both Wans are ADSL Internet with 8MBPS Download/1 mpbs upload speeds.

    our WANS are of limited bandwidth so we need this limiting to prevent people using the

    This setup works well when there is no Traffic Shaping/Limiting., it works like charm , I can see who eats most of b/w with NTOP and see over all usages with vnstat.

    As soon as i try to use a Limiter, it works for sometime then the whole network dies / crawls..

    I tried different limits/speeds however this happens even if i try to limit a small segment of my LAN.

    I tried to just use the Traffic Shaper (using single lan multi wan wizard) to prevent torrents however it made the entire network slow too.

    The Limiter seems to work fine when there is only 5-10 nodes operating at the office but when there are more than 30 using it at the time, it seems to slow everything down until we remove this limiters/ then reboot the FW.

    How do i go about trouble shooting this? I  tried a lot of searches on this forum and google and it didnt help .

    If it could help using a physical machine with multiple adapters but I believed since I just use 2x 8mbps wan i didnt really need a dedicated machine.



  • What kid of hardware are you running it on and how many CPUs and how much memory did you assign? What type of NICs are you running and what kind did you create for the virtual NICs? What version of ESX?



  • Hey thanks for taking your time to help me.

    1. ESXI 5.5

    2. Core i7 4770 / 16 GB ram

    3. VM is assigned 1 core and 1 GB ram.

    4. NIC is realteck 8169 ethernet socket available on the Gigabyte b85 d3h motherboard board

    5. I didnt specify any type of the Virtual NIC , just added 3 bridged interfaces for the VM

    Let me know if i should show you anything else.



  • Try adding another processor. IF you have one, use an Intel NIC. Not heard good things about the realtek. If you didn't specify the type it defaults to e1000 for FreeBSD VMs which is good.