Disable referercheck – didn't work



  • Hello: There is a locked post on here telling how to disable the httpreferercheck via ssh. I followed that, but it did not work. https://forum.pfsense.org/index.php?topic=56392.0

    I'm running a just-installed 2.1.2 64bit pfSense with standard kernel. When I try to login via web I get the message

    "An HTTP_REFERER was detected other than what is defined in System -> Advanced (https://<myip>:88/index.php?logout). You can disable this check if needed in System -> Advanced -> Admin."

    The command to disable the referercheck [pfSsh.php playback disablereferercheck] was issued and succeeded. I even looked through the config.xml and found the <nohttpreferercheck>there in the webgui section.

    Just another frustration as I try to figure out how to route my new 8-block of IPs!

    Perhaps my config is just too weird, with the LAN side being a real IP address.</nohttpreferercheck></myip>