Pfsense having trouble installing squid while snort is installed



  • Hello just a littel heads up, im ferly new to Pfsense and I came a cross a error that dident make any sense for me.

    I installed PFsense and Snort, then i went in and configured it as decribed on the forums and it seemd to work just fine, got some "false posetive" as I were expecting due to a fear amont of warnings on the guides on the forum. So I dindt really give it much tought and went head on installing Squid, or tryed would be a more correct term, It kept halting for some reason. So I restarted the PFsense and gave it another try, still it were failing to manage to install Squid. Then i realised that Snort may take this as "threath", so I went on disabeling the WAN and LAN configuration on SNORT, gave Squid installation another go, and it all seems to work now. So just a heads up



  • Nothing odd going on there. Snort's HTTP inspector will throw a lot of false positives, which was likely the case here too.



  • Jeah the post were meant as an heads up, for new userts. That Snort mau cause some problems reguarding installing new packets later on, due to false posetives. And my own stupidety reaguarding me to sett Snort to block all "supicius" traffic  ;D



  • After updating to never version i have issues installing every package. I actually have  this problem:

    Beginning package installation for squid3 .
    Downloading package configuration file… done.
    Saving updated package information... done.
    Downloading squid3 and its dependencies...
    Checking for package installation...
    Downloading https://files.pfsense.org/packages/amd64/8/All/squid-3.1.22_1-amd64.pbi ...  (extracting)
    Loading package configuration... done.
    Configuring package components...
    Additional files... squid.inc failed.
    Backing up libraries...
    Removing package...
    Starting package deletion for squid-3.1.22_1-amd64...done.
    Removing squid3 components...
    Tabs items... done.
    Menu items... done.
    Services... done.
    Loading package instructions...
    Include file squid.inc could not be found for inclusion.
    Deinstall commands...
    Not executing custom deinstall hook because an include is missing.
    Removing package instructions...done.
    Auxiliary files... done.
    Package XML... done.
    Configuration... done.
    Cleaning up... done.
    Failed to install package.

    Installation halted.

    I will try to disable snort and hope the best?

    Many thnx for this tip. It could solve mine problem, cause i COULD install snort...

    Many many thnx