MTU not applied to certain interfaces



  • There is a problem with setting interface MTU through the web interface. I have different kinds of interfaces set up with special MTU settings for some of them. It turns out, not all settings are applied properly, checked with ifconfig.

    | **| Name | Type | Configured MTU | Actual MTU |
    | WAN | PPPoE | auto | 1492 |
    | LAN | Physical | 9000 | 1500 |
    | RIPE | Physical | 9000 | 1500 |
    | MAN | Physical | auto | 1500 |
    | BR_LAN | Bridge | 9000 | 1500 |
    | 6IN4 | GIF | 1472 | 1472 |
    | PUBLICWLAN | VLAN | 9000 | 9000 |

    2.2-ALPHA (amd64)
    built on Thu Apr 17 04:15:34 CDT 2014
    FreeBSD 10.0-STABLE


    P.S. Noticed something interesting as well, not strictly related to pfSense.

    vmx0 options=60079b <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,tso4,tso6,lro,rxcsum_ipv6,txcsum_ipv6>vmx1 options=61039b <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,tso4,tso6,vlan_hwfilter,rxcsum_ipv6,txcsum_ipv6>vmx2 options=60039b<rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,tso4,tso6,rxcsum_ipv6,txcsum_ipv6></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,tso4,tso6,rxcsum_ipv6,txcsum_ipv6></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,tso4,tso6,vlan_hwfilter,rxcsum_ipv6,txcsum_ipv6></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,tso4,tso6,lro,rxcsum_ipv6,txcsum_ipv6>
    

    How come three physically similar interfaces (all VMXNET3) have different options available? Is it related to vmx1 having a VLAN assigned to it and vmx2 being down?** |



  • Please share your config.xml at least the interfaces part.

    The other is normal if you have vlan assigned.



  • Thank you! As for the file, here it is (part of it, anyway):

     <interfaces><wan><enable><if>pppoe0</if>
            <blockpriv><blockbogons><ipaddr>pppoe</ipaddr>
            <spoofmac></spoofmac></blockbogons></blockpriv></enable></wan> 
        <lan><enable><if>vmx1</if>
    
            <ipaddr>192.168.1.1</ipaddr>
            <subnet>24</subnet>
            <ipaddrv6>2001:67c:2158:a019::1</ipaddrv6>
            <subnetv6>120</subnetv6>
            <blockbogons><spoofmac><mtu>9000</mtu></spoofmac></blockbogons></enable></lan> 
        <opt1><if>vmx2</if>
    
            <enable><spoofmac><mtu>9000</mtu></spoofmac></enable></opt1> 
        <opt2><if>vmx0</if>
            <enable><ipaddr>dhcp</ipaddr>
            <dhcphostname><alias-address><alias-subnet>32</alias-subnet>
            <dhcprejectfrom><adv_dhcp_pt_timeout><adv_dhcp_pt_retry><adv_dhcp_pt_select_timeout><adv_dhcp_pt_reboot><adv_dhcp_pt_backoff_cutoff><adv_dhcp_pt_initial_interval><adv_dhcp_pt_values>SavedCfg</adv_dhcp_pt_values>
            <adv_dhcp_send_options><adv_dhcp_request_options><adv_dhcp_required_options><adv_dhcp_option_modifiers><adv_dhcp_config_advanced><adv_dhcp_config_file_override><adv_dhcp_config_file_override_path><blockbogons><spoofmac></spoofmac></blockbogons></adv_dhcp_config_file_override_path></adv_dhcp_config_file_override></adv_dhcp_config_advanced></adv_dhcp_option_modifiers></adv_dhcp_required_options></adv_dhcp_request_options></adv_dhcp_send_options></adv_dhcp_pt_initial_interval></adv_dhcp_pt_backoff_cutoff></adv_dhcp_pt_reboot></adv_dhcp_pt_select_timeout></adv_dhcp_pt_retry></adv_dhcp_pt_timeout></dhcprejectfrom></alias-address></dhcphostname></enable></opt2> 
        <opt3><if>bridge0</if>
            <enable><spoofmac><mtu>9000</mtu></spoofmac></enable></opt3> 
        <opt4><if>gif0</if>
            <enable><blockbogons><spoofmac><mtu>1472</mtu></spoofmac></blockbogons></enable></opt4> 
        <opt5><if>vmx1_vlan4</if>
            <enable><ipaddr>192.168.2.1</ipaddr>
            <subnet>24</subnet>
            <ipaddrv6>2001:67c:2158:a019::2:1</ipaddrv6>
            <subnetv6>120</subnetv6>
            <blockbogons><spoofmac><mtu>9000</mtu></spoofmac></blockbogons></enable></opt5></interfaces>