Watchguard Firebox x500 Problem



  • Hi everyone!

    I've been using pfSense on the fairly popular Watchguard Firebox x500 hardware for quite a while now, and today while I was editing some VPN configuration through the web GUI, the system locked up completely and I had to power it off at the mains.

    Upon trying to restart the box I was surprised to find that it no longer seems to get past POST, theres no BIOS beep, nothing on the LCD and only the Arm/Disarm LED flashing on the front. Does anyone know what the problem could be? I've tried booting the box without the CF card and any other unnecessary hardware in place but still nothing :(

    I'm hoping it's something as simple as a bad CF card, but I don't have another to hand right now, so if anyone can confirm whether they've experienced anything like this with the Firebox before, it would be much appreciated! As I understand it they're fairly hard to brick, so I'm hopeful that it's not something to do with the BIOS ROM!

    Thanks in advance,
    Gary


  • Netgate Administrator

    Try clearing the CMOS. Check the battery if it hasn't been powered off for a while.
    Try re-seating everything (RAM, CPU, PSU connector), careful with the exposed PSU!
    Unfortunately those boxes are all quite old now and are known to suffer from bad capacitors at times.

    Steve



  • Hi Steve, thanks for the advice. One of the first things I did was try re-seating everything inside, I've also checked the CMOS battery voltage with a multimeter and it seems to be still good.

    Strangely after leaving it overnight it decided to power up again this morning for a while, however after running for 15 minutes or so it locked up again and is back to not booting, I fear it may be dry solder joints seeing as it had time to cool overnight.

    I'll persevere with it and if I get anywhere I'll report back to the community.

    Ta
    Gary



  • Right, I have made progress!

    I'm beginning to think it was a faulty memory module, while I did re-seat it I never tried swapping it out.
    After the box booted to just a beep a couple of times I suspected it may be on the blink, so I've popped a spare stick of PC133 RAM I had in there and it's booting every time now.

    I'll keep an eye on it, but hopefully that resolves the issue.

    Cheers,
    Gary


  • Netgate Administrator

    Nice.  :)
    Unusual for a DIMM that old to fail so spectacularly but not unknown I guess.

    Steve