Alix board vs linksys wrt54g dd-wrt strength



  • Hello community,

    I have bought an Alix Board http://www.amazon.de/ALIX-2D13-ALIX-Bundle-Board-Engines/dp/B004ZPXOYK, with an antenna http://www.amazon.de/CSL-Stabantenne-Signalverst%C3%A4rker-Omni-direktionale-Wlan-Stick/dp/B00DZSKCUW/ref=sr_1_4?ie=UTF8&qid=1387900247&sr=8-4&keywords=wlan+antenne and an wlan card:
    http://www.amazon.de/TP-LINK-TL-WN861N-WLAN-Mini–PCI-Adapter/dp/B009ODRRDM/ with installed pfsense 2.1.2

    and have a linksys wrt54g with dd-wrt running.

    Bot connected to the same Modem, same Wlaname, same Channel and wireless strength set to maximum.

    But when i check the strength of both wlans the wireless signal of linksys is by far stronger than from pfsense?
    And the range are from both approximately the same. No important difference.

    It is completely strange for me because pfsense has a 12dpi huge antenna and linksys has two small one.

    So do i have something else to configure by pfsense or why is the signal so weak? I think for a 12dpi antenna the signal is very bad.

    Thanks


  • Netgate Administrator

    Using two antennas can be a big advantage especially if you have a lot of signal reflection.

    That card has two antenna connectors are you sure you have the correct one selected for both Tx and Rx? Having either trying to use the connector without an antenna makes a huge difference.

    Steve


  • Banned

    Any particular reason for this double-post?

    https://forum.pfsense.org/index.php?topic=75650



  • TX and RX should be the same antenna(s), or the mismatch of the channel matrix will cost you at least 3dB, possibly more if you are running 2.2 and have one of the MIMO modes running.

    Speaking as someone who, and decade ago had a depth of knowledge of the Atheros cards unmatched outside of Atheros and it's customers, the txpower parameter is unlikely to behave in a manner that you understand.  Best to leave it alone.

    If you're not running a 2.2 snapshot, try that.



  • Any particular reason for this double-post?

    I am really sorry, this account is used from two persons, but we haven`t checked enough who is writing what. So a double post will not occure anymore.

    TX and RX should be the same antenna(s), or the mismatch of the channel matrix will cost you at least 3dB, possibly more if you are running 2.2 and have one of the MIMO modes running.

    Tx is set two 2 and RX is set to default. I will check this out, to set both to the same. I will give my feedback

    Speaking as someone who, and decade ago had a depth of knowledge of the Atheros cards unmatched outside of Atheros and it's customers, the txpower parameter is unlikely to behave in a manner that you understand.  Best to leave it alone.

    But when i let the default value i have not enough wireless strength to go around the corner, so my only option was to set this value to 99. Maybe it will better work with RX also set to 2. Then I will lower the value.

    Running 2.1.2



  • the wireless support in FreeBSD 8.3 (the base for pfSense 2.1/2.1.1/2.1.2) is not great.

    You'll have better luck with pfSense 2.2 (which runs FreeBSD 10 as a base).  The 802.11 support there is much, much better.


  • Netgate Administrator

    Just to be clear on this if you only have one antenna then you need to make sure that both Tx and Rx are using it. I.e. they both need to be set to the same antenna number.
    Secondly there doesn't seem to be any rational way of determining which antenna connector on the card corresponds to which antenna number in the driver. Fortunately it's easy to determine which one it is experimentally since you will get massively better range with the correct number selected.

    Steve



  • So, I am waiting for pfsense 2.2. Hopefully there is really a better wireless support. I am really curious.  :)

    So changed the number for TX and RX to the same, sadly no better connection.
    I also tested the other driver number, but there I had no signal, so I am sure that the connector is on the right one.

    I have shifted around the antenna and tested the wireless signal, brought no improvement.



  • So, I am waiting for pfsense 2.2.

    If you are just setting up and testing then 2.2 development snapshots are available, so it is possible to play and try how it works so far.



  • Thanks now I am in the stress, but end of june I will test version 2.2 (or hopefully the final version ;-) )

    Because now i have another problem with pfsense, but this is another topic

    Greetings