Squid3 reverse proxy config (HTTPS not redirecting)



  • Hi,

    I'm playing around with pfSense 2.1.2 and Squid3 (also tried Squid3-dev). I use squid for it's reverse proxy capabilities.

    In my network I have 3 webservers, let's call them WEB1, WEB2 and WEB3. They are all serving websites on port 80 (HTTP protocol). But on WEB2 is a collaboration platfom (Open Project), that holds sensitive information. So I want the connection to be secure (HTTPS protocol).

    I configured squid to use HTTP and HTTPS reverse proxy, set up the webservers (all protocl HTTP and port 80) and made mappings for the websites (for WEB2 I made 2 mappings, one HTTP and one HTTPS). I also made CA and a server certificate in the cert manager, and linked the certificate to the HTTPS reverse proxy in squid.

    All my websites are accessible, also the HTTPS Open Project site (the self-signed certificate warning comes up and when I accept it the website comes up).

    So far so good…

    Now the next thing is what I can't seem to get working.

    When people type in http://team.openproject.com, I want them to be redirected to https://team.openproject.com. So I made a redirect in squid on protocol HTTP for team.openproject.com (without regex, cause I don't really know what to type in there) to https://team.openproject.com. (tried it in all possible ways I can think of, nothing is working), the HTTP site keeps working and not redirecting.

    Can anyone point me in the right direction ?

    Do I need Squid3 or Squid3-dev to accomplish this ?
    Do I need to change the protocol for WEB2 under webservers tab ?
    Do I need to make changes to the mappings ?
    Is the redirect wrong ? Regex ?

    Any help would be appreciated, I'm struggling with this for days now!

    Thanks in advance...