Wont stay connected to Gateway

  • Hi I am new to pfsense so this may be a simple question but I cant seem to find the answer anywhere.

    My Pfsense system will connect to the gateway on interface WLAN and get ip and DNS, my clients can also surf the internet for about 5 seconds then for some reason the internet stops. I check the gateway page and it says its no longer connected. I also check the log and get this error.

    Apr 21 00:05:14 apinger: ALARM: WAN_DHCP( *** down ***

    On the main status page and It shows that the WLan still has a ip and it know the DNS but I get no internet. Re-starting the apinger service does not help. If I Release and Renew the interface of WLan I get my internet back for another 5 seconds but then the same thing happens. I also have 2 separate computers which I installed PFsense on and both have the same problem. My internet provider is SureWest Fiber.

    Any help would be appreciated.

  • I have been working on this for a few hours now with no luck. I did upgrade to 2.1.2 and now I can stay connected for 15 min but it then disconnects again. Does anyone have any ideas on what I could try.

  • To get going, you could disable gateway monitoring on WAN GW (System->Routing).
    What address is set for the monitor IP?
    (Is it default, use the address of the ISP gateway, or is alternative monitor IP specified?)
    Can you ping that gateway monitor IP from an ordinary LAN client?
    Can you keep pinging it for a long time? Or does that address refuse to respond to pings that go on for a long time?

    Maybe try or (Google DNS)as alternative monitor IP. They should be happy to respond to the pfSense ping every second.

  • @phil.davis:

    They should be happy to respond to the pfSense ping every second.

    Don't be so sure. I had to up my interval to 10 seconds after my ICMP traffic started getting knocked down to both 8.8 and 4.4. May have been my ISP that did it, but somewhere along the line someone didn't appreciate it :(

  • Thanks for your reply, I wont be able to try all your ideas again for a few days since i'm traveling. I did disable monitoring though and setting the DNS to use the Google DNS as you said. I have the monitoring IP set to default, well its blank which in the notes says that leaving it blank would use the WAN default IP. I left the monitoring time blank which defaults to 10, but I did also set it manually to 10. I will try pinging the gateway monitoring IP and see what happens.

  • I was able to try your suggestions, When the clients loose internet connection I tried to ping the gateway WAN ip from the "Status: Dashboard" page and it was able to get a response with no issues but internet was still down. What was weird is that I when i first connected back I got internet for about 35 min and I thought it cleared up but then the problem came back and I was dropped again within 10 seconds for releasing and renewing the gateway interface.

    One thing weird that I did notice is that I setup up a Dynamic DNS in pfsense and when I try to connect to my ftp server using the Dynamic dns it gets translated to a different ip then whats on the pfsense WAN. It seems that their is an ip above the WAN ip for my internet, if that makes sense. But when I hook up my netgear router setup up with Dynamic DNS and i connect to my ftp using the Dynamic address the IP it gets translated to is what is assigned to my router.

  • Hi anyone have any new thoughts on this problem? During this time I have tries 2 other Linux firewall software packages on the same hardware and don't have this problem but would really like to use pfsense.

Log in to reply