6rd / _stf creation fails



  • This is seen on the console during boot:

    pfsense_interface_rename expects parameter 1 to be string, array given on /etc/inc/interfaces.inc line 3393

    This line (and the few above) seem to be creating the _stf-interface/6rd-gateway. This now fails, and no wan_stf interface is present. 6rd does not work (although, 6rd has not worked in 2.1.1 either since january 18th 2013, see bug 2882).



  • That is because the module needs to be loaded and it return an error.
    Will fix for next snap.



  • Great! Tried the latest snap right now and the error is still there. Will try them as you make them.



  • To check if you have the fix.

    Just run kldstat and you should have if_stf in the output.
    If not the module is not loaded.

    Try loading yourself with kldload if_stf.ko and click save on interfaces page.
    That will remove the error.



  • The module was not loaded, just as you suspected, kldstat only showed one module: kernel.

    I loaded it with kldload, went to WAN interface and clicked save. After some delay I noticed pfSense rebooting. Same error (since the module was not in /boot/loader.conf). My WAN was dead and did not get an IP. I tried a few things, including manually setting the interface to DHCP and rebooting. Nothing worked.

    I then restored my config.xml and all was well again, i.e. back to square one. But no if_stm and no module. Then added the module to /boot/loader.conf which resulted in crash and reboot loop on "Configuring wan interface….". Had to revert. So all in all I had no progress.

    On a side-note, in the console, when selecting 2) Set interface(s) IP address, selecting WAN and choosing dhcp: the resulting message (probably because no IP received due to abovemention misconfig):

    The IPv4 WAN address has been set to dhcp
    You can now access the webConfigurator by opening the following URL in your web browser:
                      http://dhcp/

    This URL could perhaps trip up a newbie or two.



  • I tried the latest snap just now.

    After kldload if_stm.ko and clicking save on the WAN, the console spews a lot of errors and the (virtual) machine reboots. The /var/log/system.log shows:

    panic: if_clone_createif: lookup failed for stf

    On a side-note, the console shows after upgrade:

    Firmware upgrade complete. Rebooting in 10 seconds

    For far more than 10 secs.
    Text could perhaps be adjusted so people won't believe the upgrade has halted altogether.



  • While 6rd does not work yet (see other reports and posts, effectively boiling down to https://redmine.pfsense.org/issues/2882), setting up the 6rd config on wan does no longer cause spontaneous reboots. This thread can be retired.